# TABLE OF CONTENTS

**Chapter 1 – Getting Started**

- What is BrightAuthor?, What kind of presentations can I create? ........................................ 1
- What type of screen layouts can I use?, Step 1: Get the hardware you need ......................... 2
- Step 2: Install the BrightAuthor software, Step 3: Launch BrightAuthor................................. 4
- Step 4: Set up your BrightSign unit, Step 5: Add your content .............................................. 5
- Step 6: Create your presentations, Step 7: Publish your presentations ................................. 6

**Chapter 2 – Setting up Units**

- Adding BrightSigns to your BrightSign Network ................................................................. 7
- Adding BrightSigns to your Local Network ........................................................................... 11
- Adding BrightSigns to your Simple File Network ............................................................... 13
- Setting up BrightSigns for standalone use ........................................................................... 17
Chapter 3 – Creating Presentations .................................................................20

Creating a full-screen presentation ...............................................................20
Creating a multi-zone presentation ...............................................................22
Adding RSS, Text, and Media RSS Feeds ......................................................26
Adding Live Video and SignChannel ..............................................................27
Adding and creating Dynamic Playlists .........................................................27
Making a presentation interactive .................................................................28
Adding Media Lists and Play Files .................................................................37
Adding Live Text and Interactive Menus .......................................................42
Adding User Defined Events .........................................................................52
Adding Event Handlers ..................................................................................54
Adding Commands .........................................................................................55

Chapter 4 – The TD1012 .............................................................................58

Chapter 5 – BP900 and BP200 Button Boards ............................................60
## Chapter 6 – Publishing Presentations

- Publishing with Local Storage ................................................................. 63
- Publishing with BrightSign Network ......................................................... 66
- Publishing with Simple File Networking .................................................. 69
- Publishing with Local Networking ............................................................ 73

## Chapter 7 – Customizing Presentations

- Setting zone properties ........................................................................... 77
- Customizing template layouts ................................................................. 80
- Setting presentation properties ............................................................... 82
- Setting default properties .......................................................................... 87

## Chapter 8 – Managing your Network

- Permissions, Viewing unit statuses ....................................................... 89
- Manging Groups ...................................................................................... 91
- Viewing Presentations .............................................................................. 92
CHAPTER 1 - GETTING STARTED

What is BrightAuthor?
BrightAuthor is a software application that helps you create presentations for your digital sign or kiosk. You can play your BrightAuthor presentations on BrightSign models: HD110, HD120, HD210, HD210w, HD220, HD410, HD810, HD1010, HD1010w, HD1020, and TD1012. Your presentations can include any of the following types of content:

- Images
- Pre-recorded videos
- Live videos (HD810, HD1010, and HD1010w)
- Audio
- RSS
- Dynamic Playlists
- SignChannel (HD210, HD210w, HD220, HD1010, HD1010w, HD1020 and TD1012 only. Subscription is required. Go to http://www.signchannel.com/ for details)
- Text
- Date or time

What kind of presentations can I create?
You can create two types of presentations with BrightAuthor:

- Non-Interactive: A slide show of media that plays in a continuous loop. You can play non-interactive presentations on all BrightSign models.
- Interactive: A presentation that transitions between media based on input from a user via a button board, remote control, or a similar input device. All models except the HD110 support at least one type of interactive event.
What type of screen layouts can I use?
You can choose from a variety of ready-to-use layout templates or create your own template. Layout templates fall into two basic categories:

- Full Screen: A slide show of media that occupies the full screen.
- Multi-Zone: A presentation with different types of content in separate regions of the screen. The screen can include one video or background image zone, and multiple Clock, Text, Ticker, and Image zones.

Step 1: Get the hardware you need
To create and play presentations with BrightAuthor, you need the following:

- Windows PC
- BrightSign
- Display
- Storage card
- Card reader/writer (optional if using USB storage)
- Input device (optional)

**Windows PC** – Any Windows PC that meets or exceeds the following *minimum* requirements:

- 2.3 GHz CPU
- 2 GB RAM required (4 GB recommended)
- 100 MB available hard disk space for program files (additional disk space required if storing content and/or presentations on your hard disk)
- One of these operating systems:
  - Windows Vista 32 or 64 bit
  - Windows 7 32 or 64 bit

**BrightSign** – Any of the following models with firmware version 3.8.34 or later:

- HD110
• HD210 and HD210w
• HD410
• HD810
• HD1010 and HD1010w
• TD1012

Any of the following models with firmware version 4.0.13 or later:
• HD120
• HD220
• HD1020

**Display** – Any monitor, TV, or Elo touch screen with one of the following types of inputs:
• VGA
• Component (HD810, HD1010, and HD1010w only)
• HDMI

**Storage for Media** – Either of the following:
• USB Flash Drive (HD810, HD1010, HD1010w, and HD1020 only)
• SD card
• SDHC card
• SDXC card (HD120, HD220, and HD1020 only)

**Card Reader/Writer** – Not required if using a USB flash drive. The card reader/writer must be connected to your PC and must be compatible with your storage card.

**Input Device** – All models except HD110. One or more of the following types of input devices:
- Touch screen equipped with a touch controller that supports the standard HID specification. For a list of all supported touch controllers, see the following link: http://support.brightsign.biz/entries/262256-whattouchscreens-can-i-use-with-the-brightsign. (HD810, HD1010, HD1010w, and HD1020 only)
- Many brands of USB Keyboards (HD810, HD1010, HD1010w, and HD1020 only)
- Many brands of USB Mouse or Trackballs (HD810, HD1010, HD1010w, and HD1020 only)
- Many brands of USB Bar Code Scanners (these appear as a keyboard; HD810, HD1010, HD1010w, and HD1020 only)
- Quadravox Serial Button Board
- AMX, Crestron, and similar control devices (serial & Ethernet)
- Any GPIO (open/close contact switch) button, signal, or LED (your custom board or LED display). USB button boards can be purchased from the BrightSign website: http://www.brightsign.biz/products/expansion_module.php
- PC via serial port
- IR remote control using the NEC Remote Control Protocols (HD810, HD1010, HD1010w, and HD1020 only). You can purchase a compatible remote from BrightSign (see Appendix A for remote control codes).

**Step 2: Install the BrightAuthor software**

Download the latest software and install it on your PC.

1. Go to the BrightSign web site: www.brightsign.biz/support.
2. Click the BrightAuthor Downloads link.
3. Follow the onscreen instructions to install the software on your PC.

**Note:** BrightAuthor requires the latest version of Microsoft .Net Framework. If this component is not already on your PC, BrightAuthor installs it during the installation. However, if BrightAuthor needs to install Microsoft .Net Framework, the installation may take up to 45 minutes to complete and you may need to restart your PC to complete the installation process.

**Step 3: Launch BrightAuthor**

1. Double-click the BrightAuthor icon on your desktop.
2. (Optional) If prompted, sign in to BrightSign Network (account required). See Publishing with BrightSign Network.

Step 4: Set up your BrightSign unit
1. Depending on how you want to publish your presentations, create the appropriate setup files for your BrightSign units.
2. Insert the SD card or USB flash drive that contains the setup files into the BrightSign.
3. Connect your BrightSign to a display.

Step 5: Add your content
Your BrightAuthor presentations can include the following types of media files:

Video files - BrightSigns support the following video file encodings/compressions:
- MPEG-2 (can be saved as a .mpg, .ts, or .vob container)
- MPEG-1 (can be saved as a .mpg container)
- H.264 (MPEG-4, Part 10) (can be saved as a .mp4, .mov, or .ts container)
For further details on video file encoding and support, see the following link: http://support.brightsign.biz/entries/143091-what-video-formats-and-codecs-does-the-brightsign-support.

Audio files - BrightSigns support the following audio formats:
- AAC (LC - Low complexity profile) at Constant Bit Rate, as part of a video file (.mp4, .mov, or .ts) at 44.1 KHz, 48 KHz
- MP2 (MPEG-1 Layer 2) at Constant Bit Rate, as part of a video file (.mpg, or .ts) at 44.1 KHz, 48 KHz
- MP3 at Constant Bit Rate, 44.1 KHz, 48 KHz, 32 KHz at up to 224 Kbps bitrate, as a standalone file (i.e. not encoded as an audio track in a video file)
- AC3 5.1 passed through (un-decoded, RAW data) HDMI. Audio streams in this format are supported by BrightSigns, but will require an AC3 decoder (HDMI AV receiver).
- WAV
Images files - For still images, use BMP, PNG, or JPEG files. The maximum supported resolution is 1920x1080.

Step 6: Create your presentations
Now you're ready to start using BrightAuthor to create presentations. Just add your content and follow the directions in the next chapter of this guide to create your presentations.

Step 7: Publish your presentations
After creating presentations, use the publishing feature to deliver them to your BrightSign units. See Publishing Presentations for details.
CHAPTER 2 – SETTING UP UNITS

Before you can create and publish presentations for your BrightSign units, you must first set up the players. How you set up your units will depend on how you want to publish presentations to the players. If you’re using BrightSign Network, Local Networking, or Simple File Networking to publish your presentations, you must set up your BrightSign units by adding them to your network. Alternatively, you can set up BrightSigns for use as standalone units that are not connected to a network. With this option, you would have to manually update the BrightSign’s storage (SD card or USB flash drive) each time you want to update presentations. For more details on each of the publishing methods, see Publishing Presentations.

To set up a player, you need to create setup files in BrightAuthor and add those files to storage device (SD card or USB flash drive). Next, insert the storage into the BrightSign. It is important to keep in mind that this storage must remain inside the BrightSign. BrightSign units have no internal storage and therefore cannot receive content without a storage device connected. Once the storage is inserted (typically an SD card), your BrightSign is ready to receive and play presentations.

Adding BrightSigns to your BrightSign Network

To publish and manage presentations using BrightSign Network, you must first contact BrightSign to obtain an account name, user name, and password. After you obtain your account credentials, you can create the setup files for each unit.

After you obtain your account credentials, you can create the setup files for each unit. The setup files provide details about your network and BrightSign Network connections, where the presentations associated with the selected group are stored, and when to run the presentations.

1. Sign in to your BrightSign Network account.
   a. In the BrightAuthor menu bar, click Tools > Sign in to BrightSign Network.
   b. If prompted, enter your Account, User name, and Password, and then click Sign In.
2. On the menu bar, click Tools > Setup BrightSign Unit.
3. Under Name Specification, do the following:
a. Enter a **Name** and **Description** for this unit.
b. Select whether you want to append the unit ID to the name or use only the name.
- **Time zone**: Select the time zone where the unit is located.
- **Time server**: Select the clock for this unit.
- **IP address**: Indicate whether the IP address is auto-generated or static. If you’re using a static IP address, enter the parameters in the fields below.
- **Use proxy**: Check the checkbox if you want to use a proxy server. Type the address and port number in the fields below.
- **Wired/Wireless**: Indicate whether the network is wired or wireless and enter the SSID and Security key if the network is secured.

4. Click **Specify Firmware Update** to indicate whether you want to update the firmware and to which version. The Firmware Update window is divided by BrightSign model. In the section that corresponds to your BrightSign unit, select a firmware version or **Do not update**, and then click **OK**.

5. Under **Unit Configuration**, click **Networked with BrightSign Network**, and then specify the following:
   - **(Optional) Enable diagnostic web server**: Check the checkbox to enable the diagnostic web server. You can include a username and password in the text fields below for added security.
   - **(Optional) Enable local web server**: Check the checkbox to enable the local web server. You can include a username and password in the text fields below for added security.
• **Group**: Use the dropdown list to select a group for the unit. Groups allow you to publish presentation schedules to multiple units simultaneously. See [Managing groups](#) and [Publishing with BrightSign Network](#) for details.

• **Network connection frequency**: Set how often you want the unit to check the server for updates.

• **Limit content downloads**: Set a time frame during which downloads can take place.

• **Copy content from the current published schedule**: Check this to checkbox if you are setting up a unit but already have presentations scheduled. This will copy the current schedule to the storage device and thereby reduce initial download time when setting up the unit.

6. Under **Logging**, check any of the following checkboxes to enable/disable logs, and specify upload settings:
   - **Enable playback logging**: Creates a log that specifies when a playlist was used.
   - **Enable event logging**: Creates a log that specifies when events are triggered.
   - **Enable diagnostic logging**: Creates a log that provides troubleshooting information.
   - **On startup**: Uploads log files each time you start the unit.
   - **At specific time each day**: Uploads log files daily, at the specified time. Use the dropdown lists to pick a time.

7. (Optional) Under **Rate Limit Network Download Traffic**, set parameters for downloading media traffic. The options are divided into **Outside content download window**, **During content download window**, and **During initial downloads**.
   - Click **Unlimited download rate** to set no limit.
   - Click **Default limit** to use the default limit on downloads.
   - Click **Specify limit** to enter a customized limit on downloads in the text field (in Kbits/second).

8. Create and install the setup files:
   a. Click **Create Setup Files**.
   b. Browse to and select an SD card (recommended) or USB flash drive (HD810, HD1010, HD1010w, and HD1020 only) to store the setup files.
   c. Click **OK**.
   d. Turn off the BrightSign unit by unplugging the power adapter. Insert the card or flash drive into the unit.
   e. Turn on the BrightSign unit by reconnecting the power adapter.
Important: Do not remove the SD card or flash drive from the player.

Adding BrightSigns to your Local Network
With local networking, the setup files provide details about where presentations are stored and whether logging options are enabled.

1. In the BrightAuthor menu bar, click Tools > Setup BrightSign Unit.
2. Under Name Specification, do the following:
   a. Enter a Name and Description for this unit.
   b. Select whether you want to append the unit ID to the name or use only the name.
3. Under Network Properties, set the following:
   • Time zone: Select the time zone where the unit is located.
   • Time server: Select the clock for this unit.
   • IP address: Indicate whether the IP address is auto-generated or static. If you're using a static IP address, enter the parameters in the fields below.
   • Use proxy: Check the checkbox if you want to use a proxy server. Type the address and port number in the fields below.
   • Wired/Wireless: Indicate whether the network is wired or wireless and enter the SSID and Security key if the network is secured.
4. Click Specify Firmware Update to indicate whether you want to update the firmware and to which version.
The Firmware Update window is divided by BrightSign model. In the section that corresponds to your BrightSign unit, select a firmware version or Do not update, and then click OK.
5. Under **Unit Configuration**, click **Networked with Local File Networking**, and then specify the following:
   - (Optional) **Enable diagnostic web server**: Check the checkbox to enable the diagnostic web server. You can include a username and password in the text fields below for added security.
   - (Optional) **Enable local web server**: Check the checkbox to enable the local web server. You can include a username and password in the text fields below for added security.

6. Under **Logging**, check any of the following checkboxes to enable/disable logs:
   - **Enable playback logging**: Creates a log that specifies when a playlist was used.
   - **Enable event logging**: Creates a log that specifies when events are triggered.
   - **Enable diagnostic logging**: Creates a log that provides troubleshooting information.

7. Create and install the setup files:
   a. Click **Create Setup Files**.
   b. Browse to and select an SD card (recommended) or USB flash drive (HD810, HD1010, HD1010w, and HD1020 only) to store the setup files.
   c. Click **OK**.
   d. Turn off the BrightSign unit by unplugging the power adapter. Insert the card or flash drive into the unit.
   e. Turn on the BrightSign unit by reconnecting the power adapter.

   **Important**: *Do not remove the SD card or flash drive from the player.*

### Adding BrightSigns to your Simple File Network

With simple file networking, the setup file provides details about your network, the web folder associated with a unit, where presentations are stored, and when to check for updates.

1. In the BrightAuthor menu bar, click **Tools > Setup BrightSign Unit**.
2. Under **Name Specification**, do the following:
   a. Enter a **Name** and **Description** for this unit.
   b. Select whether you want to append the unit ID to the name or use only the name.
3. Under **Network Properties**, set the following:
- **Time zone**: Select the time zone where the unit is located.
- **Time server**: Select the clock for this unit.
• **IP address**: Indicate whether the IP address is auto-generated or static. If you’re using a static IP address, enter the parameters in the fields below.

• **Use proxy**: Check the checkbox if you want to use a proxy server. Type the address and port number in the fields below.

• **Wired/Wireless**: Indicate whether the network is wired or wireless and enter the SSID and Security key if the network is secured.

4. Click **Specify Firmware Update** to indicate whether you want to update the firmware and to which version. The Firmware Update window is divided by BrightSign model. In the section that corresponds to your BrightSign unit, select a firmware version or **Do not update**, and then click **OK**.

5. Under **Unit Configuration**, click **Networked with Simple File Networking**, and then specify the following:

   • (Optional) **Enable diagnostic web server**: Check the checkbox to enable the diagnostic web server. You can include a username and password in the text fields below for added security.

   • (Optional) **Enable local web server**: Check the checkbox to enable the local web server. You can include a username and password in the text fields below for added security.

   • **URL for the web folder**: Set the location from which the player will download presentations. Do not use trailing slashes in your URL; some web servers do not support trailing slashes.
Important: The URL for the web folder must be identical to the web folder URL you enter when publishing presentations. See Publishing with Simple File Networking for details.

- **Network connection frequency**: Set how often you want the unit to check the server for updates.
- **Limit content downloads**: Set a time frame during which downloads can take place.

6. Under **Logging**, check any of the following checkboxes to enable/disable logs, and specify upload settings:
   - **Enable playback logging**: Creates logs that specify when a playlist was used.
   - **Enable event logging**: Creates logs that specify when events are triggered.
   - **Enable diagnostic logging**: Creates logs that provide troubleshooting information.
   - **On startup**:Uploads log files each time you start the unit.
   - **At specific time each day**: Uploads log files daily, at the specified time. Use the dropdown lists to pick a time.
   - **Relative URL for log handler**: Type the location where you want logs to be uploaded.

7. (Optional) Under **Rate Limit Network Download Traffic**, set parameters for download traffic. The options are divided into **Outside content download window**, **During content download window**, and **During initial downloads**.
   - Click **Unlimited download rate** to set no limit.
   - Click **Default limit** to use the default limit on downloads.
   - Click **Specify limit** to enter a customized limit on downloads in the text field (in Kbits/seconds).

8. Create and install the setup files:
   a. Click **Create Setup Files**.
   b. Browse to and select an SD card (recommended) or USB flash drive (HD810, HD1010, HD1010w, and HD1020 only) to store the setup files.
   c. Click **OK**.
   d. Turn off the BrightSign unit by unplugging the power adapter. Insert the card or flash drive into the unit.
   e. Turn on the BrightSign unit by reconnecting the power adapter.

Important: Do not remove the SD card or flash drive from the player.
Setting up BrightSigns for standalone use

Standalone players are not connected to a network and must be updated manually. To change presentations/schedules, you must remove the storage card (or USB flash drive), update it on your computer, and reinsert it into the player.
Updating standalone units is the only case in which you should remove the storage card after setting up the unit. If your player has a USB flash drive slot, it is recommended that you use an SD card when setting up the unit, and keep it in the player as the internal storage. You can update the content on the SD card via a USB flash drive. See Publishing with Local Storage for details. With standalone units, the setup files provide details about where presentations are stored and whether logging options are enabled.

1. In the BrightAuthor menu bar, click **Tools > Setup BrightSign Unit.**
2. Under **Name Specification**, do the following:
   a. Enter a **Name** and **Description** for this unit.
   b. Select whether you want to append the unit ID to the name or use only the name.
3. Under **Network Properties**, set the following:
   - **Time zone**: Select the time zone where the unit is located.
   - **Time server**: Select the clock for this unit.
   - **IP address**: You can still set an IP address for players that are not networked. Indicate whether the IP address is auto-generated or static. If you’re using a static IP address, enter the parameters in the fields below.
   - **Use proxy**: Check the checkbox if you want to use a proxy server. Type the address and port number in the fields below.
4. Click **Specify Firmware Update** to indicate whether you want to update the firmware and to which version.
The Firmware Update window is divided by BrightSign model. In the section that corresponds to your BrightSign unit, select a firmware version or Do not update, and then click OK.

5. Under Unit Configuration, click Networked with Local File Networking, and then specify the following:
   - (Optional) Enable diagnostic web server: Check the checkbox to enable the diagnostic web server. You can include a username and password in the text fields below for added security.
   - (Optional) Enable local web server: Check the checkbox to enable the local web server. You can include a username and password in the text fields below for added security.

6. Under Logging, check any of the following checkboxes to enable/disable logs:
   - Enable playback logging: Creates a log that specifies when a playlist was used.
   - Enable event logging: Creates a log that specifies when events are triggered.
   - Enable diagnostic logging: Creates a log that provides troubleshooting information.

7. Create and install the setup files:
   a. Click Create Setup Files.
   b. Browse to and select an SD card (recommended) or USB flash drive (HD810, HD1010, HD1010w, and HD1020 only) to store the setup files.
   c. Click OK.
   d. Turn off the BrightSign unit by unplugging the power adapter. Insert the card or flash drive into the unit.
   e. Turn on the BrightSign unit by reconnecting the power adapter.

Important: Unless you are updating content, do not remove the SD card or flash drive from the player. See Publishing with Local Storage for details.
CHAPTER 3 – CREATING PRESENTATIONS

Creating a full-screen presentation

In a full-screen presentation, your images or videos occupy the entire screen.

1. Create a new presentation project:
   a. Double-click the BrightAuthor icon on your desktop.
   b. Click File > New Presentation
   TIP: If you don't see New Presentation under File, make sure you have the Edit, Publish, or Manage tab selected in the upper-left portion of the screen.
   c. In the New Project window, enter a name for the presentation in the Save as field.
   d. In the Where field, enter the folder where you want to store the presentation. Click Browse to navigate to the desired folder.
   e. Select your BrightSign model, Connector type, Screen resolution, and Monitor orientation.
   f. Select a Monitor overscan setting to control how the image fills the display screen.
      • No overscan: Displays images all the way to the edge of the video signal.
      • Overscan - action safe: Restricts the image display to an area that is compatible with most displays.
      • Overscan – title safe: Restricts the image display to an area that is much smaller than the image generated by the video signal.
   Tip: Experiment to find the overscan setting that works best with your display.
   g. Click Create.
2. Click the Full screen template, and then click Choose.

3. Add media to your Library:
   a. In the left portion of the screen, under the File tab, click Browse.
   b. Navigate to the folder where your content is stored.
   c. Click OK.

   **Note:** If you have a lot of large files in your content folder, it may take a while for the thumbnail images to appear.

4. Add media files to your presentation by dragging files from the Media Library folders to the playlist area. Make sure you have the Files tab selected, under Media Library.
   a. To select a series of adjacent media files, press Shift+Click as you select the files.
   b. To select a group of non-adjacent files, press Ctrl+Click as you select the files.
   c. To set the order in which the files play, drag them to the Playlist area in the proper order. You can change the order of files already in the playlist by clicking a file and dragging it to a new position.
   d. To refresh the Media Library folders, click the refresh icon (next to the Browse button).
   e. To remove an item from a playlist, click it in the playlist area and press Delete on your keyboard.
   f. To change media files in the playlist without individually deleting and dragging, click File > Replace media files. In the Replace Media Files window, click Browse to select the folder that contains the files you want to add. This can be the same folder used in your Media Library or a new folder. A list of all files currently added to the playlist is displayed below Presentation Media Files. For each file you want to replace, select a new file using the dropdown lists beneath Replacement Media File.
   g. To create interactive events, see Making a presentation interactive.

2. (Optional) Rename the playlist:
   a. Click Edit in the upper-right corner of the playlist area.
   b. Enter a new name for the playlist.
   c. Click OK.

6. (Optional) Set playback options:
   a. To edit settings for a single item, right-click the thumbnail in the playlist area, select Edit, and then choose the settings you want to apply to the selected item.
b. To edit settings for multiple items, press Ctrl+Click to select the items in the playlist area. On the menu bar, click Edit > Selected Items, and then choose the settings you want to apply to the selected items.

7. On the menu bar, click File > Save… to store your presentation.

Note: Make sure you have the Edit tab selected in the upper-left portion of the screen. To save the presentation with a different name or in a different folder, select File > Save… As. To export the presentation and associated content, select File > Export….

Creating a multi-zone presentation

In a multi-zone presentation, BrightAuthor divides the screen into rectangles called zones. You can play different content in each zone and each zone supports a specific type of content. BrightAuthor provides a handful of multi-zone templates. You can choose one of the existing templates, or create your own (see Customizing presentations).

When using a multi-zone template, you need to know which type of content you can include in each zone. The color-coded key at the bottom of the template screen shows the available content types, and the color-coded templates indicate which type of content you can include in each zone of the templates. The following list describes the available content types:

- **Images**: Plays images. You can include multiple Images zones.
- **Ticker**: Plays an RSS feed or pre-defined text strings. You can include multiple Ticker zones.
- **Clock**: Displays the time or date. You can include multiple Clock zones.
- **Video or Images**: Plays videos and images. You can include only one Video or Images zone.
- **Video Only**: Plays videos. You can include only one Video Only zone.
- **Audio Only**: Plays audio. You can include multiple Audio Only zones.
- **Background Image**: Places an image in the background of your presentation. All other zones appear on top of the background image. When using a background image, you cannot include a Video Only zone or a Video or Images zone. You can include only one Background Image zone.

Note: You can include only one zone with video per presentation. Therefore you must choose between a Video or
Images zone, a Video Only zone, or a Background Image zone. You cannot have more than one of these zone types in the same presentation.

1. Create a new presentation project:
   a. Double-click the BrightAuthor icon on your desktop.
   b. Click File > New Presentation
   **Tip:** If you don’t see New Presentation under File, make sure you have the Edit, Publish, or Manage tab selected in the upper-left portion of the screen.
   c. In the New Project window, enter a name for the presentation in the Save as field.
   d. In the Where field, enter the folder where you want to store the presentation. Click Browse to navigate to the desired folder.
   e. Select your BrightSign model, Connector type, Screen resolution, and Monitor orientation.
   f. Select a Monitor overscan setting to control how the image fills the display screen.
      - No overscan: Displays images all the way to the edge of the video signal.
      - Overscan - action safe: Restricts the image display to an area that is compatible with most displays.
      - Overscan – title safe: Restricts the image display to an area that is much smaller than the image generated by the video signal.
      **Tip:** Experiment to find the overscan setting that works best with your display.
   g. Click Create.

2. Click the multi-zone template you want to use, and then click Choose.

3. Add media to your Library:
   a. In the left portion of the screen, under the File tab, click Browse.
   b. Navigate to the folder where your content is stored.
   c. Click OK.
   **Note:** If you have a lot of large files in your content folder, it may take a while for the thumbnail images to appear.

4. Add content to the zone playlist:
   a. Click the zone you want to populate.
   **Note:** Each zone has its own playlist.
b. Under the **File** tab, drag items from the Media Library folders to the playlist area. Click **Browse** to change the Media Library folder.
• To select a series of adjacent media files, press **Shift+Click** as you select the files.
• To select a group of non-adjacent files, press **Ctrl+Click** as you select the files.
• To set the order in which the files play, drag them to the Playlist area in the proper order. You can change the order of files already in the playlist by clicking a file and dragging it to a new position.
• To refresh the Media Library folders, click the refresh icon (next to the Browse button).
• To remove an item from a playlist, click it in the playlist area and press **Delete** on your keyboard.
• To change media files in the playlist without individually deleting and dragging, click **File > Replace media files**. In the Replace Media Files window, click **Browse** to select the folder that contains the files you want to add. This can be the same folder used in your Media Library or a new folder. A list of all files currently added to the playlist is displayed below **Presentation Media Files**. For each file you want to replace, select a new file using the dropdown lists beneath **Replacement Media File**.
• To create interactive events, see **Making a presentation interactive**.

5. Repeat step 4 for each zone in the presentation.

6. Click the **Layout** tab to add new zones or adjust the position of your zones. To add a new zone, click the **Add Zone** button. In the New Zone window, type a name for the zone in the **Zone name** text field, and select a zone type. Click **OK**. To adjust the position and size of zones, drag and resize in the preview in the right portion of the screen. See **Customizing template layouts** for further details.

7. (Optional) Rename the playlist:
   a. Click **Edit** in the upper-right corner of the playlist area.
   b. Enter a new name for the playlist.
   c. Click **OK**.

8. (Optional) Set playback options:
   a. To edit settings for a single item, right-click the thumbnail in the playlist area, select **Edit**, and then choose the settings you want to apply to the selected item.
   b. To edit settings for multiple items, press **Ctrl+Click** to select the items in the playlist area. On the menu bar, click **Edit >Selected Items**, and then choose the settings you want to apply to the selected items.
9. (Optional) Set zone properties. See Setting zone properties for details.

10. On the menu bar, click **File > Save…** to store your presentation.

**Note:** Make sure you have the *Edit* tab selected in the upper-left portion of the screen. To save the presentation with a different name or in a different folder, select **File > Save… As**. To export the presentation and associated content, select **File > Export…**.

### Adding RSS, Text, and Media RSS Feeds

Networked BrightSigns can include RSS feeds. These can include RSS feeds (text) or Media RSS (feeds that contain videos or images). Alternatively, you can create your own text feeds and add them to a Ticker zone like an RSS feed. Note: text feeds are static whereas RSS and Media RSS feeds are updated each time the BrightSign connects to the server. This is ideal for instant updates from sources such as Twitter.

**Text Feeds** – To add a text feed, create a text file that contains the text. Insert a line break between each text item in the text file. Save the text file and place it in your Media Library folder. Select a Ticker zone in your presentation, click the **Text** tab, and then drag the text file into the playlist. Repeat this step to add additional text files.

**RSS Feeds** – To add an RSS feed, select a Ticker zone in your presentation, click the **RSS** tab and drag the ![New RSS Feed](image) icon into the playlist. When prompted, enter the URL for the RSS feed and click **OK**. If you want to add a Twitter feed, drag the ![Twitter](image) icon into the playlist. When prompted enter the Twitter User Name and click **OK**.

**Media RSS** – To add a Media RSS feed, click the **Other** tab below Media Library. Drag the ![Media RSS Feed](image) icon to the playlist area. When prompted, type the URL for the feed and click **OK**.

**Note:** You can include multiple Ticker zones in your presentations. To adjust the update frequency for RSS feeds, click **File > Presentation Properties**. Under the *Main* tab, use the dropdown list beside **RSS Update Frequency**.
Adding Live Video and SignChannel
BrightSigns HD810, HD1010, and HD1010w support Live Videos. All networked players support SignChannel content. For SignChannel, a subscription is required. See www.signchannel.com for details.

Live Video – Select a Video or Images, or Video only zone. Under the Other tab, drag the Live Video icon to the playlist area. To edit the video volume and time on screen, double-click the thumbnail in the playlist area. When prompted, make the desired edits.

SignChannel – Under the Other tab, drag the SignChannel icon to the playlist area. Note: SignChannel content can only be in one zone of your presentation.

Adding and creating Dynamic Playlists
A Dynamic Playlist enables you to easily update and share content in multiple presentations. Let’s say you need to add daily announcements to your presentations, and you don’t want to update each presentation separately. You can add a Dynamic Playlist to all of your presentations and insert a new video announcement in the Dynamic Playlist each day. When you upload the revised Dynamic Playlist to the network, every presentation that includes the Dynamic Playlist receives the new content, so a single update reaches multiple presentations. To use Dynamic Playlists, you must have a BrightSign Network account.

Creating a Dynamic Playlist:
1. Click the Create tab in the upper-left portion of the screen.
2. On the menu bar, click File > New Dynamic Playlist. You can also open previously created Dynamic Playlists by clicking File > Open Dynamic Playlist. You can then make edits to the playlist.
3. Add files to your Media Library by clicking the Browse button and selecting a folder that contains the files you want to include in your Dynamic Playlist.
4. Drag the files to the playlist area.
5. Click the Upload to Network button in the upper-right portion of the screen.
6. You will be prompted to save the playlist. Click Yes. The Save As window will open. Type a name for your playlist and click Save. The Save Complete window will open. Click OK. The playlist will now upload onto the BrightSign Network. Click OK.

Now, all presentations that contain the Dynamic Playlist will automatically receive the new content. You change the content of the Dynamic playlist at any point by opening the playlist (File > Open Dynamic Playlist) and dragging new media files into the playlist area.

**Adding Dynamic Playlists:**

1. Open a presentation project.

2. Click the Edit tab.

3. Under the Other tab, drag the Dynamic Playlist icon to the playlist area.

4. The Add Dynamic Playlist window will open. From the drop-down list, select which Dynamic Playlist you want to link to the current presentation. Click OK.

**Making a presentation interactive**

You can use BrightAuthor to create interactive presentations. Interactive presentations respond to interactive events, such as input from buttons or other GPIO devices, or from devices connected to a BrightSign communication port. The supported communication methods vary by BrightSign model.

**RS232 serial devices:** HD410, HD810, HD1010, HD1010w, and HD1020

**USB devices (such as touch screens, mice, keyboards, barcode scanners, IR remote controls):** HD810, HD1010, HD1010w, and HD1020 (see Appendix A for remote control codes)

**Ethernet devices:** HD210, HD210w, HD220, HD1010, HD1010w, and HD1020
To make your presentation interactive, complete the following steps:

1. Open a presentation project. If you haven’t already created a presentation, see Creating Presentations for details.
2. Add files to your Media Library by clicking the Browse button and selecting a folder that contains the files you want to include in your presentation.
3. Click a zone you want to make interactive. Note: multi-zone presentations can include both non-interactive and interactive zones.
4. Make the zone interactive. In the upper-right portion of the screen beside Playlist type, click Interactive.
5. Drag the desired content into the playlist area.
6. Choose a Home Screen. The Home Screen is the first media file in the playlist. It is where the interactive presentation begins (within a particular zone).

Home Screens usually include one of the following:

- An attract video that loops until the user provides input
- A list of options from which the user can choose the next action (e.g. an Interactive Menu)

By default, the first item you drag into an interactive playlist will become the Home Screen. It is identified by the Home icon. You can change the Home Screen at any time by double-clicking the desired file in the playlist and checking the Set as initial state box.

7. Define Interactive Events. Interactive events link files in the playlist and determine what must occur before a file transitions to another file. In the user interface, files are referred to as “states”, where the current file is the “current state”, and the file transitioned to is the “next state”. In this guide, creating and linking interactive events between files will be referred to as “defining events”:
   a. In the Event Toolbar, click the interactive event icon that corresponds to the type of event you want to define. For example, to define what happens when a user presses button 1 on a button board, click .
   b. Click (and hold) the file name below the thumbnail image of the current. This media file is what the user sees before performing the interactive event you are about to define.

**Note:** The first interactive event must begin with the Home Screen.
   c. Drag the hand pointer to the thumbnail image of the media file you want to play next (the next state).
d. Repeat steps a – c to define the remaining interactive events.
Subsequent interactive events can start with any item and correspond to any other item in the playlist. For example, you can set the first interaction to display an image when the user presses button 1 from the Home screen. By defining a new event with the same event icon, you can set a second interaction to display another media file when the user presses button 1 again.
Make sure your defined events work in a loop. In the above screenshot, a user can transition from the Home Screen to the other images by pressing button 1 or button 2. After a set period of time (indicated by the timeout events), the presentation will return to the Home Screen.

Multiple interactive events can be utilized to transition from state to state. You can also apply events to multiple items. Click and drag in the playlist area to create a selection box. Then, define the interactive event from one media file and it will be created for all selected files. To select non-consecutive files, press and hold Ctrl while clicking items.

In the upper-right portion of the screen, you can use the Zoom control to adjust your view of the playlist area. When switching between multiple interactive zones, BrightAuthor will remember last used zoom setting for each zone.

If you don’t see the event you want in the playlist toolbar, click the arrow to the left of the Zoom control. Here, you can add or remove event icon buttons from your toolbar. You can also access Event icons by clicking the Events tab under Media Library.

When creating an event with an Event icon from the Events tab, drag the event icon onto the thumbnail of the media file you want to be the current state. An Event window will automatically open. Here, you can specify which media file you want to be the Next state. See below step (e) for details.

   e. (Optional) Edit transitions. You can further adjust how your media files transition from state to state by double-clicking the event icons (or right-clicking and then clicking Edit).

For example, if you create an event with the Timeout Event icon, the media file displayed in your presentation will transition to the next state after a certain period of time. You can adjust this time period by double-clicking the Timeout Event icon between the two media files and changing the duration in the Timeout Event window.
The Event window that opens when double-clicking a created event icon is the same window that automatically opens when you drag an event icon from the Events tab. The window always presents options specific to the type of interactive event chosen. However, every Event window displays the following options:

- **Transition to new state**: Use the dropdown list to specify which file in the playlist will be the next state.
- **Return to prior state**: If you select this option, the presentation will revert to the previous media file when the interactive event is performed.
- **Remain on current state**: If you select this option, the state will not change when the interactive event is performed. This option is useful for creating changes within one media file. You can create these changes by adding commands. See [Adding Commands](#) for details.
- **Advanced**: Click the Advanced arrow to reveal the display options and commands section. Here you can set how you view the interactive events between states in the playlist area. **Show line** draws a line between the media files. **Show label** creates a label either to the Right or Bottom of the media file which indicates transitions from states. See [Adding Commands](#) for details on commands.

f. (Optional) Edit files. You can edit individual files in the playlist by right-clicking and then clicking **Edit**. The Media Properties window will open.

![Media Properties window](image)
Here, you can view/change the **State name** and **Current file**. Use the dropdown list beside **Select different file** to swap the file with another in the playlist area. This is convenient for keeping the interactive events you have defined with the original file. Replacing media files can also be done under **File > Replace Media Files**. See [Creating Presentations](#) for details. Use the dropdown list beside **Transition** to create a special transition effect when the file appears on the display. Check the **Set as initial state** checkbox to change the file to make the file the Home Screen. Use the dropdown list beside **Transition** (image files only) to create a special effect for the image. Click the **Advanced** arrow to store the image in a cache, set display mode for video files (2D, 3D side-by-side, 3D top-over-bottom), and add commands. See [Adding Commands](#) for details.

### g. You can delete a defined event (or file) at any time by clicking the icon/thumbnail and pressing **Delete** on your keyboard.

Interactive events can include any of the following. For each, make sure you define the next state after dragging the icon onto the current state:

<table>
<thead>
<tr>
<th>Event Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Timeout" /></td>
<td>Displays an item for a predetermined period of time before the next action occurs automatically. To define the length of the timeout interval, double-click the <strong>Timeout</strong> icon in the playlist area. In the <strong>Specify timeout (seconds)</strong> field, enter the number of seconds you want the item to display, and then click <strong>OK</strong>.</td>
</tr>
<tr>
<td><img src="image" alt="Media End" /></td>
<td>Sets the action that occurs after a video or audio file finishes playing.</td>
</tr>
<tr>
<td>Event Icon</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>-------------</td>
</tr>
<tr>
<td><img src="image" alt="GPIO Event" /></td>
<td>Sets the action that occurs when a specific GPIO button/input is pressed or activated. By default, the playlist toolbar includes several GPIO buttons which you can use to define interactions.</td>
</tr>
<tr>
<td><img src="image" alt="BP900A Event" /></td>
<td>Sets the action that occurs when a specific BP900 or BP200 button is pressed. There are six icons: BP900A, BP900B, BP900C, BP200A, BP200B, and BP200C. See BP900 and BP200 Button Boards for details.</td>
</tr>
<tr>
<td><img src="image" alt="Synchronize" /></td>
<td>Synchronizes content with another BrightSign on the same network. To define the connection, drag the Synchronize icon onto the current state. When the Synchronize Event window opens, enter a trigger in the Specify synchronization keyword field, and then click OK. Note: the same event/trigger must be defined for each transition you want synchronized.</td>
</tr>
<tr>
<td><img src="image" alt="UDP Input" /></td>
<td>Sets the action that occurs when a BrightSign receives input from a network device. Use this event when you want an external device to control BrightSigns using UDP (User Datagram Protocol or Universal Datagram Protocol). To define the trigger, drag the UDP Input icon onto the current state. When the UDP Input Event window opens, enter the network address for the external device in the Specify UDP input field, and then click OK.</td>
</tr>
<tr>
<td><img src="image" alt="Serial Input" /></td>
<td>Sets the action that occurs when a BrightSign receives specific input from a device connected to the serial port. To define the input, drag the Serial Input icon onto the current state. When the Serial Input Event window opens, enter the serial string that triggers the next event in the Specify serial input field, and then click OK.</td>
</tr>
<tr>
<td>Event Icon</td>
<td>Description</td>
</tr>
<tr>
<td>------------------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><img src="image" alt="Rectangular Touch" /></td>
<td>Sets the action that occurs when the user touches the specified rectangular area on a touchscreen. To define the area, drag the <strong>Rectangular Touch</strong> icon onto the current state. When the Add Touch Event window opens, drag the box to resize the touch area (or enter the exact <strong>Size</strong> and <strong>Position</strong>). To add additional touch regions to the selected item, click <strong>Add Touch Region</strong>, and define the parameters, and then click <strong>OK</strong>.</td>
</tr>
<tr>
<td><img src="image" alt="Keyboard Input" /></td>
<td>Sets the action that occurs when a BrightSign receives specific input from a keyboard. To define the keyboard input, drag the <strong>Keyboard Input</strong> icon onto the current state. When the Keyboard Input Event window opens, enter the keyboard input that triggers the next event in the <strong>Specify keyboard input</strong> field, and then click <strong>OK</strong>.</td>
</tr>
<tr>
<td><img src="image" alt="USB Input" /></td>
<td>Sets the action that occurs when a BrightSign receives input from a device connected to the USB port. To define the trigger, drag the <strong>USB Input</strong> icon onto the current state. When the USB Input Event window opens, enter the USB input that triggers the next event in the <strong>Specify USB input</strong> field, and then click <strong>OK</strong>.</td>
</tr>
<tr>
<td><img src="image" alt="Remote Input" /></td>
<td>Sets the action that occurs when BrightSign receives specific input from a remote control (IguanaWorks USB transceiver required). To define the remote input, drag the <strong>Remote Input</strong> icon onto the current state. When the Remote Input Event window opens, enter the remote character that triggers the next event in the <strong>Specify remote input</strong> field, and then click <strong>OK</strong>. See <strong>Appendix A</strong> for remote control codes.</td>
</tr>
<tr>
<td><img src="image" alt="Zone Message" /></td>
<td>When combined with Sync Events, synchronizes multiple zones across separate displays. To define the zone message, drag the <strong>Zone Message</strong> icon onto the current state. When the Zone Message Event window opens, specify the zone message trigger. Use this event with multi-zone video walls. For synchronizing multi-zones in one display, use a Link Zones event. Note: the same event/trigger must be defined for each transition you want synchronized.</td>
</tr>
<tr>
<td>Event Icon</td>
<td>Description</td>
</tr>
<tr>
<td>--------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><img src="link-zones-icon.png" alt="Link Zones" /></td>
<td>Synchronizes content in another zone. To define the link, drag the <strong>Link Zones</strong> icon onto the current state. When the Link Zones Event window opens, enter the trigger in the <strong>Specify link keyword</strong> field, and then click <strong>OK</strong>. Note: the same event/trigger must be defined for each transition you want synchronized.</td>
</tr>
<tr>
<td><img src="video-time-code-icon.png" alt="Video Time Code" /></td>
<td>Performs commands at specific times during video playback. To define the commands and times, drag the <strong>Video Time Code</strong> icon onto the current state (video file). When the Video Time Code Events window opens, click <strong>Add Time Code</strong>, enter the <strong>Timeout</strong> interval, select the <strong>Command</strong> and <strong>Parameters</strong> from the corresponding lists, and then click <strong>OK</strong>. For more details, see <a href="#">Adding Commands</a>.</td>
</tr>
</tbody>
</table>

**Adding Media Lists and Play Files**

Media Lists and Play Files are convenient tools for defining interactive events with many files. They allow you to compile your files into one big group that appears as a single thumbnail in your playlist area. Only files of the same type can be gathered in a Media List or Play File. Therefore, both are divided into 3 categories for each media type:

- **Media Lists** - Image List, Audio List, and Video List.
- **Play Files** - Image Play File, Audio Play File, and Video Play File.

Under the **Other** tab, there is an icon for each List and File type. To create a Media List or Play File, drag the appropriate icon into the playlist area of a corresponding zone.
**Media List** – By default, each time an item transitions to a Media List, the next file in the list will play and exit the list after a timeout (images) or when the file finishes playing (video and audio). Alternatively, you can set the list to shuffle files or cycle through every file in the list before exiting and transitioning to the next state.
After setting your zone to **Interactive** and dragging a Media List icon into the playlist area, the List window will automatically open. Here, you can set the following parameters for your List:

- **Media list name**: Create a unique name for the list.
- **Set as initial state**: Check this checkbox to make the list your Home Screen.
- **Advance to next item on media end event**: Check this checkbox to set the list to cycle to the next file in the list after a timeout or media end event. If you leave this box unchecked, the list will play one file each time it is transitioned to, and select the next file in the list upon subsequent transitions.

**Note**: If the list is an Image List, this parameter will say **Advance to next item on Image Timeout** instead. Immediately below, you can set the time period by typing in the text field beside **Image Timeout (seconds)**.

- **Play from beginning on entry to state**: Check this checkbox to set the list to play from the beginning upon entry into the list. This box is only enabled if you have checked the above **Advance to next item on media end event**. If you leave this box unchecked, after a user exits the list (e.g. via a command), subsequent transitions to the list will play the next file in the cycle.
- **Shuffle playback**: Check this checkbox to randomize the order in which files are played from the list.
- **Event to transition to next item**: Select an interactive event that allows the user to transition to the next file in the list. After selecting the event type, you must specify a trigger.
- **Event to transition to previous item**: Select an interactive event that allows the user to transition to the next file in the list. After selecting the event type, you must specify a trigger.

**Note**: If you leave event transitions on the default **None**, timeouts and media end events will automatically cause transitions.

- **Media Library**: Click **Browse** to select the folder that contains all the files you want to include in the list.
- **Media Files**: Add individual files to the list by clicking the **Add File** button and using the dropdown list. Only files contained the folder you selected above will be available in the dropdown list.
- **Commands**: Add commands to the list. See [Adding Commands](#) for details.

You can edit properties of your Media Lists under **File > Presentation Properties > Media List** tab. See [Setting presentation properties](#) for details.
**Play File** – Play Files also combine files into a list you can view in one window (or as one thumbnail in the playlist area). However, Play Files function quite differently. They allow transitions to specific files within the group. In addition, any type of interactive event can cause a transition to a Media List. Play Files on the other hand, can only be transitioned to via input from BP900/BP200, UDP, Serial, Keyboard, or USB. Although, any type of event can transition out of Play File and to a new state. Make sure you use zones that match the Play File type you want to use.
After setting your zone to Interactive and dragging a Play File icon to the playlist area, the Play File window will automatically open. Here, you can set the following parameters for your List:

- **State name**: Create a unique name for the Play File. This name will show up in the thumbnail in the playlist area.
- **Transition** (Image Play Files only): Use the dropdown list to create a special effect when a user transitions to an item in the Play File list.
- **Files**: This list displays files added to your Play File. Each file has a **Key** and **File Path**.
  - **Key**: The key is the specific interactive event that will cause a transition to a particular file. Because you define the interactive events with the keys in the Play File, you do not need to specify the events again when creating a transition to the Play File. For example, if you define a USB Input event that links an item to the Play File, the option to Specify USB Input will be disabled and replaced with <any>. When a user performs an event via USB that matches a key, the corresponding file will play.
  - **File Path**: This is the location of the file on your computer.
  - **Display Mode**: Only Video Play Files have a display mode. By default, files are set to 2D, but if you are using a 3D video, you can select 3D side-by-side or 3D top-over-bottom when adding your files.
- **Add File**: Click this button to add items to the Play File. Here, you can specify the Key, File Path (use the Browse button to navigate to the desired file), and Display Mode if using a video file (use the dropdown list to select a display mode). Click OK when finished.

![Add File dialog](image)

- **Import Table**: Click this button to import a previously created list of files. Navigate to your saved table and click Open to add the files to your Play File list. This table must have the Key, File Path, File Name, and Video Display
Mode (if applicable) properly outlined. For a detailed explanation on importing a table for a Play File state, read the article on our website: http://brightsign.zendesk.com/entries/21135706-how-do-i-create-and-import-a-table-for-a-play-file.

- **Commands**: Add commands to your Play File here. See Adding Commands for details.

Click **OK** when you are finished.

**Adding Live Text and Interactive Menus**

These two features allow you to customize content for more engaging presentations. Live Text is an image laced with various text fields. With Live Text, you can layer both static and updateable RSS text on top of images or videos and customize the position/size of the text in relation to the background.

Interactive Menus are DVD style menus which users can navigate across with interactive events. By linking separate media to items in the Interactive Menu, you can allow users to interactively transition to a new state of their choice. Because they can serve as a bridge to many items and outline everything available to the user, Interactive Menus make great Home Screens.

**Live Text** – To use Live Text, drag the Live Text icon from the **Other** tab to the playlist area and set the following parameters:

- **State name**: Type a unique name for the Live Text file.
- **Set as initial state**: Check the checkbox to make the Live Text your Home Screen.
- **Background Image**: Click **Browse** to locate and select a background image for your Live Text.
- **Text Data Update Frequency**: Use the dropdown lost to set how often you want to update your RSS text feeds.
- **Update Live Text Data**: Click this button to immediately update all RSS feeds.
- **Size**: Adjust the size of your text fields. **W** corresponds to the width of the text field, and **H** corresponds to the height of the text field.
- **Position**: Adjust the position of your text fields. \( X \) corresponds to the position of the text on a horizontal axis. \( Y \) corresponds to the position on a vertical axis.

**Note**: Input numbers in the Size and Position fields for more precise results. Alternatively, you can click and drag the text fields in the preview to adjust size/position.
• **Offset next**: Check this checkbox to automatically set a position for subsequent text items (in relation to the most recent text item). Input the distance for the next text item in the X and Y fields.

• **Text type**: Use the dropdown list to select Fixed Text, System Variable, Live Text Data, Media Counter, or User Variable.
  
  o Fixed text: Select this option if you want to type your own text. A text field will appear below Text Type where you can type your customized text. As you type, you can view the text in the preview image.
  
  o System variable: This can include the device Serial number, Firmware version, or Script version. Use the dropdown list to select one for your text field.
  
  o Live Text data: Select this option if you want an updateable RSS feed in your text field. Input the URL for the RSS feed in the **Live Text Data URL** field below. If you know the exact title for the content you want, input it in the **Item title** field. Or, if you know the index number, input it in the **Item index** field. When using the **Item index**, subsequent RSS text fields will automatically contain the next item in the index (i.e. the previous index number + 1).
  
  o Media Counter: Media Counters display how many times a file in the presentation has played. Each Media Counter field must correspond to a specific file. Use the dropdown list to pair the Media Counter field with a file in the presentation. To use this feature, Media Counters must first be enabled. Under **File > Presentation Properties > Variables** tab, check the **Automatically create media counter variables** checkbox.
  
  o User variable: User variables are customizable values that can be used in commands. User variables in Live Text display the current value of the specified User variable. Use the dropdown list to specify a User variable for the text field. To use this feature, you must first create your User variable(s). For more details, see [Setting presentation properties](#).

• **Validate Live Text Data**: Click this button to verify a valid source (URL) for your feed.

• **Set Text Parameters**: Click an individual text field, and then click this button to edit parameters for that text field. Subsequent text fields will automatically contain the text parameters of the previous text field. You can edit the Number of lines, Rotation, Alignment, Foreground text color, Background text color (this appears behind each text field), Transparency (for background text colors), Font, and under the **Advanced** arrow, the Background bitmap and Safe text region. See [Setting zone properties](#) for details on text parameters.
Note: BrightAuthor 2.5 and earlier versions required a Background Text Color for each text field. Now, you can use the checkbox beside Background Text Color to decide whether you want to include a Background Text Color. If you choose to include one, the Transparency setting will become enabled and you can edit the Transparency of the Background Text Color. If you choose not to include a Background Text color, the letters/numbers of the text fields will appear directly over the background image.

- Add Text Item: Click to add a new text field. Select the text field in the preview image and edit the parameters explained above.
- Previous/Next Buttons: Click these buttons to quickly switch between text fields.
- Advanced: Click to add commands. See Adding Commands for details.

As mentioned earlier, Live Text can be layered over images or videos. Keep in mind, all BrightAuthor projects can include at most one video zone.
Live Text Images: If you want to use a still image behind your Live Text, you should add the Live Text to an Images zone. Complete the following steps for each zone you want to contain Live Text:
   a. Select an Images zone. Make the zone Interactive. Drag the Live Text icon from the Other tab.
   b. In the Add Live Text window, type a State name and then click Browse beside Background Image. Locate and select your desired background image file.
   c. Click Add Text Item. Adjust the Size and Position of your text field by clicking and dragging over the preview image, or inputting exact numbers in the corresponding fields.
   d. Select your Text Type and input the desired text.
   e. Click Set Text Parameters and edit text parameters as desired. See Setting zone properties for details on each parameter. Click OK when finished.
   f. Repeat steps c – f for each text field.
   g. Click OK.

Live Text Videos: Layering Live Text over a video requires two zones because you cannot add Live Text to a Video Only zone. Instead, you can add Live Text to an Image zone, and place it on top of a Video Only zone. To help you position text over the video, you need an image file cut from the video you want to use. Complete the following steps:
   a. Under Layout, click Add Zone. Add a Video Only zone.
   b. Click Add Zone again and add an Images zone. Resize the Images zone so that it completely covers the Video Only zone.
   c. Click Playlist, and use the Zone dropdown list to select your Video Only zone. Drag the desired video file from the Media Library to the playlist area. Make the zone Interactive.
   d. Use the Zone dropdown list to select the Images zone. Make the zone Interactive. Drag the Live Text icon from the Other tab.
   e. In the Add Live Text window, click Browse beside Background Image. Locate and select an image file taken from the video file used in the Video Only zone.
   f. Click Add Text Item. Adjust the Size and Position of your text field by clicking and dragging over the preview image, or inputting exact numbers in the corresponding fields.
   g. Select your Text Type and input the desired text.
h. Click **Set Text Parameters** and edit text parameters as desired. See [Setting zone properties](#) for details on each parameter. Click **OK** when finished.
i. Repeat steps f – h for each text field.
j. When all text fields are in place, click **Clear** beside **Background Image**.
k. Click **OK**.

Clearing the Background Image removes the image from the Image zone. The text fields will appear directly over the video. By temporarily including a Background Image taken from the video, you can better position the text fields in relation to the video playing behind the Image zone.

**Interactive Menus** – To create an Interactive Menu, add a Video or Images zone to your presentation. Set the zone to **Interactive** and drag the Interactive Menu icon from the **Other** tab to the playlist area. The Add Interactive Menu window is divided into two tabs, General and Menu Items.

**General:** In this tab, you will select an image for your Interactive Menu and define how a user navigates across it.
- **State name:** Create a unique name for your Interactive Menu.
- **Background Image:** Click **Browse** to select an image you want to act as your menu display.

**Important:** *The background image is not simply a background for the actual menu items. It must contain all images and text you want displayed in the menu.*
- **Set as initial state:** Check this checkbox to set the Interactive Menu as the Home Screen.

The Navigation section is where you define how a user navigates across the menu. Click the dropdown menu for each option (Up, Down, Left, Right, Enter, Back, Next clip, Previous clip) and select the type of event you want to utilize (GPIO Event, Serial input, etc.). A second dropdown menu or text field will appear. Specify the button or input you want to correspond to the action you are defining.

Let’s say you want to define how to move **Up** in the menu, and you want to use a keyboard event. In the dropdown list across **Up**, select **Keyboard Input**. A text field will appear below where you can specify a button. Type “U” here. Now,
when a user presses “U” on a keyboard, the cursor will move up along the menu items. You don’t need to define every possible action. You can simply leave the dropdown list on the default **None**. However, to create a more intuitive
experience between the user and menu, it might be best to define each possible action. Below are the actions available for defining in the Navigation section:

- **Up, Down, Left, Right**: These are the primary actions a user will perform to navigate from one menu item to the next.
- **Enter**: With this button, a user can select a menu item and transition to a state associated with that menu item.
- **Back**: Once a user presses the defined input for Enter on a menu item, a state you have chosen in the Menu Items tab will play. However, if you define a Back button/input, the user can return to the menu at any point.
- **Next clip**: If a user is viewing a media file associated with a menu item, pressing the defined input for Next clip will play the media file that corresponds to the next menu item.
- **Previous clip**: Pressing the defined input for Previous clip will stop the media file currently playing, and play the media file associated with the previous menu item.
- **Advanced**: Click this arrow to add commands to your Interactive Menu. See Adding Commands for details. Here, you can also store the background image in a cache. Check the checkbox to save the background image for faster loading in the future.

**Menu Items**: In this tab, you will create the menu items and further specify how a user navigates across the menu.

- **Menu Item Number**: Every Menu item has a unique Menu item number. The first one you create is 1, the second is 2, and so on. Here, you can navigate between the Menu items you have created by clicking the Previous and Next buttons. Everything else in the window corresponds to the Menu item you have selected here.

The Menu Items section is where you can create and adjust individual menu items.

- **Add Menu Item**: Press this button to create a Menu item. The Add Menu Item window will open. There are two items, the Active Image and Inactive Image. The Active image serves as a cursor which tells the user what Menu item they are on. The Inactive image is what will appear beside the current Menu item when the user navigates to a different Menu item. Use the Browse buttons to select each image. Click OK to create the menu item. By default, subsequent Menu Items you create will contain the same Active and Inactive Images.

**Tip**: If you want nothing to appear beside a Menu item when it is not selected, choose an Inactive image that matches the color of the background.
• **Position**: Adjust the position of your Menu item by inputting specific numbers. The X field corresponds to the
position of the Menu item on a horizontal axis. The $Y$ field corresponds to the position of the Menu item on a vertical axis. Alternatively, you can click the Active Image in the preview image, and drag it to the desired position. The Inactive Image will appear in the same spot when the Menu Item is not selected.

- **Offset next**: Check this checkbox to specify a Position for subsequent Menu Items in relation to the previous one. Input the data in the $X$ and $Y$ fields.
- **Selected Image**: This is the Active Image you selected when creating the Menu Item. Click **Browse** to change the image at any point.
- **Unselected Image**: This is the Inactive Image you selected when creating the Menu Item. Click **Browse** to change the image at any point.
- **Store image in cache**: This checkbox is beneath the Selected and Unselected Image. Check the box to save the corresponding image in a cache and more readily use it in the future.

The Navigation section is where you determine how a user moves from one Menu item to the next. Although the actions were previously defined in the **General** tab, this is where you specify which Menu Item a specific action brings a user to. The possible actions are **Up**, **Down**, **Left**, and **Right**. In this section, each action has a dropdown list which displays the Menu item number for each created Menu item. By default, **None** is selected for each.

Selecting a number in the dropdown list will allow the user to navigate from the current Menu Item to the specified Menu Item by performing the corresponding action. Let’s say you are adjusting the features of Menu item number 1, meaning “1” is displayed between the **Previous** and **Next** buttons at the top of the window. If you click the dropdown list for the Down action and select 2, the user can now navigate from Menu item 1 to Menu item 2 by pressing the **Down** button (remember, this button is whatever you previously defined in the Navigation section of the **General** tab).

The Enter section is where you can determine what happens when a user presses the **Enter** button on a particular Menu item. Set the following parameters:

- **Play clip**: Click the **Browse** button to select a file you want to play when the user presses the **Enter** button. If you select an image, the option to specify a timeout period will appear.
• **Transition to new state**: Here, a dropdown list contains all the media files previously placed in the playlist area of your zone. Select a file to allow the user to transition to that state after pressing **Enter**.

• **Return to prior state**: If you select this option, the presentation will display the previous state when a user presses **Enter**.

• **Remain on current state**: If you select this option, the state will not change when a user presses **Enter**. However, you can add commands to create changes that occur while remaining on the Interactive Menu. Click the **Advanced** arrow to reveal the commands section. See [Adding Commands](#) for details.

Click **OK** when you are finished. Keep in mind, if you choose **Transition to new state** instead of **Play clip**, the state will not return to the Interactive Menu.

**Adding User Defined Events**
This feature allows you to save interactive events you use often, and use them more readily in the future. Of course, all individual events can be added to your toolbar for immediate use. But with User Defined Events, the parameters for your event are saved. For example, if you frequently use a 5 second Timeout Event, you can create a User Defined Event with this specification. In the future, instead of using the Time Event icon and setting it to 5 seconds each time, you can use your previously created User Defined Event. In addition, you can group multiple events into your custom event. When defining an interaction with it, any interactive event within the User Defined Event will cause a transition to the next state. This will save you time by eliminating the need for defining each individual event. Simply create a list of events, save it as a User Defined Event, and define the event between the two states.

Click the **User Events** tab under Media Library. To create/edit User Defined Events, click **Manage**. The Manage user Events window will open. This window contains a list of all previously created User Defined Events. Complete any of the following:
• Create a User Defined Event: Click **Add User Event**. When prompted, type a unique name for your User Defined Event. Click **Add Event** and use the dropdown list to select an interactive event. Repeat for each event you want included in the User Defined Event. Click **OK** when you are finished.

![Manage User Events](image)

• Edit a User Defined Event: Click the appropriate name from the list in the Manage User Events window. Make the desired changes in the User Event window.

• Organize User Defined Events: Click the arrows to arrange the order of the list by moving a User Defined Event up or down.

• Delete User Defined Events: Click the **X** beside a name from the list. Or, click **Delete All** to erase the entire list.

To use a User Defined Event in a playlist: Click the **User Events** tab under Media Library. All previously created User Defined Events will be listed here. Drag the appropriate icon from the list onto the current state. In the Events window, specify which media file you want to be the **Next State**. Follow the usual steps for defining the event (see **Making a presentation interactive** for details).

You can also import previously created User Defined Events into BrightAuthor, or export them from BrightAuthor. Click **File > Import User Events / Export User Events**. If you are importing, browse to the location where the events are stored. If you are exporting, browse to a location where you want to export all User Defined Events currently saved in BrightAuthor.
Adding Event Handlers

There are a variety of cases in which you might want your presentation to sit at a blank screen. The Event Handler fills this role as an empty place holder in your presentation. Here are a few examples of cases in which adding an Event Handler would be convenient:

- You want a blank screen for a Home Screen so no content will play until the presentation is activated
- You want to add a command that is performed before the first file in the presentation plays
- You want the presentation to sit at a blank screen when finished, instead of looping
- You want a video file to remain on the final frame upon finishing, instead of looping

Event Handlers – Although Event Handlers contain no content, you can add commands and interactive events into and out of them. For example, if you set the Event Handler as the Home Screen and define a BP900 event linked to the first file, the display will sit at a blank screen until a user presses the BP900 button, and then the first file will begin playing. Or, if you set the Event Handler as the Home Screen and add a Sync command to it, you can synchronize your presentations/displays before the first files begin playing.

To use an Event Handler, click the Other tab under Media Library and drag the icon into the playlist area. Double-click the thumbnail in the playlist area to give a State Name, Set as initial state (Home Screen), and add commands. Click the Advanced arrow to add commands. See Adding Commands for details.

Define interactive events into and out of the Event Handler as you would with any other state. See Making a presentation interactive for details. If you define a Media End event after a video and link it to an Event Handler, the video will remain on the last frame when finished. For other file types such as images or audio, the display will sit at a blank screen when the files finish playing.
Adding Commands
To add extended functions to your presentations, you can add commands to your playlist. Commands can help control displays and devices (Display On, GPIO On, etc.) or perform additional actions when interactive events are performed (Pause Video, Set Volume, etc.).

You can add commands in three distinct ways. If you add a command to the interactive event, the command will be performed when that event occurs. When adding to an interactive event, you can either select a **Next State** or choose to **Remain on current state**. If you add a command to a media file, the command will be performed when the file plays (regardless of which state/event transitions to it).

**To add a command to an interactive event:** Double-click the event icon in the playlist area and click the **Advanced** arrow. Click **Add Command** and use the dropdown list to specify a command. Use further dropdown lists and fields to set additional parameters for the command. By default, **Next State** will be selected. You change the **Next State** by using the dropdown list and selecting a different file in the playlist area. Or, if you want the command to occur within the original file and create no state transition (e.g. increase volume of the video playing), select **Remain on current state**.

**To add a command to a media file:** Double-click the media file’s thumbnail in the playlist area and click the **Advanced** arrow. Click **Add Command** and use the dropdown list to specify a command. Use further dropdown lists and fields to set additional parameters for the command.

**Note:** There are a few other options under the **Advanced** arrow. They will depend on the type of file you have selected. For image files, you will see a **Store Image in Cache** checkbox. Check this box to save the file in a cache and more readily use it in the future. For video files, you will see **Video Display Mode**. Depending on the type of video file, use the dropdown list to select the appropriate mode (2D, 3D side-by-side, or 3D top-over-bottom). By default, 2D is selected.

Here is the list of commands you can add to your presentations:
- **BP900A, BP900B, BP900C - Set output**: Turns on and off different LED lights; sets LED lights to slow, medium, or fast blink when a button is pressed on the BP900 button board(s).
- **BP200A, BP200B, BP200C - Set output**: Turns on and off different LED lights; sets LED lights to slow, medium, or fast blink when a button is pressed on the BP200 button board(s).
- **Set audio output**: Specifies the type of audio you want to use for this item.
- **Set volume**: Specifies the volume level. Enter a value between 0 and 100.
- **Increment volume**: Specifies how much the volume level increases with each interaction.
- **Decrement volume**: Specifies how much the volume level decreases with each interaction.
- **Mute/Unmute digital audio**: Turns digital audio output on or off.
- **Mute/Unmute analog audio**: Turns analog audio output on or off.
- **Mute/Unmute HDMI audio**: Turns HDMI audio output on or off.
- **Send UDP**: Sends a command to the device using UDP protocols.
- **Serial-send string (EOL)**: Sends the specified string to the specified serial port. This command adds a carrier return at the end of the string.
- **Serial-send string (no EOL)**: Sends the specified string to the specified serial port. This command does not add a carrier return at the end of the string.
- **Serial-send byte**: Sends the specified byte to the specified serial port.
- **Serial-send bytes (comma separated)**: Sends the specified bytes to the specified serial port in comma separated format.
- **Synchronize**: Specifies the synchronization trigger.
- **Send zone message**: Specifies the zone message trigger.
- **Link zones**: Specifies the link zones trigger.
- **GPIO on**: Turns on the specified GPIO output. Other GPIO outputs are not affected.
- **GPIO off**: Turns off the specified GPIO output.
- **GPIO set state**: Enables you to turn each GPIO line on or off.
- **Pause video**: Pauses video playback.
- **Resume video**: Resumes video playback.
- **Enable monitor power save mode**: Turns the monitor's power saving mode on.
- **Disable monitor power save mode**: Turns the motor's power saving mode off.
- **BrightControl - Display on**: Turns the display on.
- **BrightControl - Display off**: Turns the display off.
- **BrightControl - Send Ascii string**: Sends a CEC command.
- **BrightControl - Philips set volume**: Sets Philips TV volume.
- **Pause**: Pauses presentation playback for a specified number of milliseconds.
- **Reboot**: Restarts the BrightSign unit.
- **Set variable**: Sets a specified value for a previously created User variable. In the Variable field, type the exact name of the variable in between two dollar signs on each side. For example, "$$variable1$$". BrightAuthor will not recognize the variable without the dollar signs. In the Value field, specify a new value for the variable. For more details on variables, see [Setting presentation properties](#).
- **Reset variables**: Resets all User variables to their original values and all Media Counters to 0. For more details on variables, see [Setting presentation properties](#).
- **Switch to Presentation**: Switches to a different presentation. The parameters set when creating the second presentation must match the first presentation. This includes: BrightSign Model, Connector Type, Screen Resolution, Monitor Orientation, and Monitor Overscan. In addition, make sure you type the exact name for the second presentation when creating the command.
CHAPTER 4 – THE TD1012

The TD1012 is a freestanding, all-inclusive, digital signage solution that you can easily place on tables, counters, or wherever signage is most needed. The TD1012’s high resolution screen and BrightSign unit are built into a durable steel casing and can be powered for approximately 12 hours by the rechargeable battery.

Creating presentations for your TD1012 is fundamentally similar to creating presentations for any other BrightSign unit. See Creating Presentations for details. However, the following details are unique to the TD1012:

- In the New Project window, the Screen resolution dropdown list only contains 1360x768x60p. This is the only resolution supported by the TD1012.
- The TD1012 does not support Audio. You may include videos in your TD1012 presentations, but no audio associated with the videos will play.

Note: When creating presentations for your TD1012 unit, you may encounter audio settings. For example, the Audio Only zone is still available when you click Add Zone. None of these audio related options apply to the TD1012.
- The TD1012 only supports wireless network connection.
- In the Template window (after clicking Create), there are only two System templates included. However, you can still add/adjust zones, and save your own custom templates. See Customizing template layouts for details.
- The TD1012 only supports interactivity through network commands. Use the UDP Input icon to define interactive events. See Making a presentation interactive for details.

Note: You can also use Timeout, Media End, Synchronize, Zone Message, Link Zones, and Video Time Code events.
- As usual, clicking the Layout tab allows you to adjust the position and size of your zones. However, the preview image in the right portion of the screen is actually rotated 90 degrees. This is because the preview image is always landscape oriented, but the TD1012’s screen is actually a portrait display. Therefore, when adjusting zones for your TD1012 presentation, refer to the image on the left side of the screen. This will show you how the zones will appear to a viewer when the presentation is playing.
Publishing and customizing TD1012 presentations is no different from other BrightSign units. See Publishing Presentations and Customizing Presentations for details.
CHAPTER 5 – BP900 AND BP200 BUTTON BOARDS

The HD810, HD1010, and HD1010w units support BP900 and BP200 button pads via the USB ports. With an Expansion Module connected to your BrightSign, you can connect a second button pad via the extra USB port. To add a BP900 or BP200 event, complete the following steps:

1. Make the presentation interactive by clicking Interactive in the upper-right side of the playlist area.
2. Define the BP900 or BP200 interactive event:
   a. Choose the proper event icon based on what kind of button pad you are using (BP900 or BP200), and how many button pads you are connecting.

   There are a total of 6 event icons: BP900A, BP900B, BP900C, BP200A, BP200B, and BP200C. The letters A, B, and C correspond to USB ports. If the event you are defining is for a button pad in USB port 1, use A. If it is for a button pad in the second port, use B, and so on. Let’s say you are using an Expansion Module and therefore have two available USB ports. If you want to connect two button boards, a BP900 and a BP200, you would use the BP900A and BP200B icons to define events for each.

   b. Define the BP900 or BP200 event as you would any other event. See Making a presentation interactive for details.

   Note: If the icon you need is not in the toolbar, click the toolbar arrow in the upper-right portion of the screen to add it to your toolbar. Or, you can click the Events tab and drag the icon to the playlist area.

   c. The BP900 or BP200 Event window will automatically open. Specify the following parameters for your event:

      • **Specify Button Number**: Select a button on the button pad that you want the user to press to transition to the next state.
      • **Press (First Touch)**: Determine whether you want the transition to occur after one push of the button.
• **Press Continuous**: Determine whether you want the user to continually press the button. Specify a repeat interval in the text field (in milliseconds).

• **Transition to new state**: Click to specify which media file in your playlist will be the Next State when the specified button is pushed.

• **Return to prior state**: Click to revert the presentation to the previous media file when the specified button is pushed.

• **Remain on current state**: If you select this option, the state will not change when the interactive event is performed. This option is useful for creating changes within one media file. You can create these changes by adding commands. See [Adding Commands](#) for details.

• **Advanced**: Click the **Advanced** arrow to reveal the display options and commands section. Here you can set how you view the interactive events between states in the playlist area. **Show line** draws a
line between the media files. **Show label** creates a label either to the **Right** or **Bottom** of the media file which indicates transitions from states. See [Adding Commands](#) for details on commands.

d. Click **OK**. Repeat steps a – c to define the remaining button pad events.
CHAPTER 6 – PUBLISHING PRESENTATIONS

After you create and save a presentation, you’re ready to publish it to your BrightSign. There are four ways to publish a presentation:

- Local Storage
- BrightSign Network
- Local Networking
- Simple File Networking

The method you use to publish should depend on several factors such as: whether your player is networked, what kind of network you have access to, and how many players you have.

**Publishing with Local Storage**

Publishing a presentation using Local Storage lets you copy your presentations to an SD card or USB flash drive. When you want to update your scheduled presentations, you must save the updated content on the SD card or USB flash drive and insert it into your BrightSign.

Unless you are updating content, an SD card or flash drive should always remain connected to the BrightSign. However, if your BrightSign has a USB port, it is recommended that you create setup files with an SD card, leave it permanently in the player as internal storage, and use a USB flash drive whenever you need to update content. You can publish updated content to the USB flash drive, insert it into the BrightSign to update the SD card, and then remove the flash drive. To publish via Local Storage, complete the following steps:

1. In BrightAuthor, save the presentations you want to publish by clicking **File > Save... As**.
2. Add the presentations you want to publish:
   a. Click the **Publish** tab in the upper-left side of the screen.
   b. Click **Local Storage** (below the **Publish** tab).
c. Under **Presentations**, click **Browse** to navigate to and select the folder where your presentations are stored.

3. Create schedules for each presentation you want to publish:
   a. From the list under **Presentations**, select a presentation.
   b. Drag the presentation to a time slot during which you want it to play.
   c. Click and drag the selection handles to adjust playing time within one day.
   d. If you want the presentation to be a recurring event, double-click the highlighted presentation name in the calendar. In the Schedule Presentation window, set the following parameters:
      - **Presentation**: Specify which presentation you want to schedule.
      - **Active all day, every day**: Check this checkbox if you want the presentation to play 24 hours a day.
      - **Event time**: Specify the time during the day when you want the presentation to play by using the dropdown lists beside **Start** and **End**.
      - **Recurring Event**: Check this checkbox if you want the presentation to recur during specified times.
      - **Recurring pattern**: Specify the frequency for the recurrence. If you click **Daily**, you can specify **Every day**, **Every weekday**, or **Every weekend**. If you click **Weekly**, you can view a checklist of every day of the week. Specify the individual days of the week when you want the presentation to play.
      - **Range of recurrence**: Use the calendar beside **Start** to specify the first day you want the presentation to play. If you want the event to stop recurring at some point, click **End by** and use the calendar to specify the date. If you don’t want it to stop, click **No end date**.
   e. Click **OK**. The adjustments made will be represented in the calendar.
   f. If prompted, indicate whether you want to replace the existing schedule and then click **OK**.
   g. Repeat steps b – e for each presentation you want to schedule.
4. (Optional) Specify debugging, logging, and firmware preferences:
   a. Under **Debugging**, use the checkboxes to enable/disable **serial debugging** and **system log debugging**.
   b. Click **Specify Logging** and use the checkboxes in the Logging window to enable/disable playback, event, and diagnostic logging.
c. Click **Specify Firmware Update** and indicate whether you want to update the firmware and to which version. The Firmware Update window is divided by BrightSign generation. In the section that corresponds to your BrightSign unit, select a firmware version or **Do not update**, and then click **OK**.

5. Publish the presentation to your storage device:
   a. Insert a storage device into your computer (SD card or USB flash drive).
   b. Under **Publish to**, click **Browse** to navigate to and select the drive where your storage device is located.
   c. If updating the SD card in the BrightSign via a USB flash drive, check the **Publish zip file for USB upgrade** checkbox. Leave unchecked if updating to an SD card or USB flash drive that will remain in the BrightSign.
   d. Click **Publish**. When the **Publish complete** window opens, click **OK**.

6. Update your BrightSign:
   a. Turn off the BrightSign unit by unplugging the power adapter.
   b. Insert the storage device from step 4 into the BrightSign.
   c. Turn on the BrightSign unit by reconnecting the power adapter.
   d. Leave the storage device in the player.

**Note:** *If an SD card is already in the player and you are updating it via USB, you don’t need to turn off the BrightSign. Insert the USB flash drive into the player, wait until the Update Complete message appears on the display, and then remove the flash drive.*

**Publishing with BrightSign Network**
Publishing with BrightSign Network enables you to distribute your presentation to your BrightSigns via an Internet connection.

BrightSign Network requires a subscription, so you must first contact BrightSign to obtain an account name, user name, and password. Once your BrightSigns are setup with BrightSign Network (see **Adding BrightSign units to your BrightSign Network**), you can upload your presentations to the BrightSign Network server and publish schedules. Your players will update their content automatically whenever they connect to the server.
Publishing with BrightSign Network sends presentations and schedules to groups instead of players. Groups can contain any number of players and you can move BrightSigns from one group to another at any point. See Managing your Network for details. To publish with BrightSign Network, complete the following steps:
1. In BrightAuthor, sign into BrightSign network by clicking **Tools > Sign in to BrightSign network**
2. Open the presentation you want to publish by clicking **File > Open presentation**.
3. Click **Upload to network** (in the upper-right portion of the screen) to upload the presentation to the server.
4. Specify which group you want to publish to:
   a. Click the **Publish** tab in the upper-left portion of the screen.
   b. Click **BrightSign Network** (above the calendar).
   c. Under **Selected Group to Schedule**, use the dropdown list to specify the group you want to publish to.
5. Create schedules for each presentation you want to publish:
   a. From the list under **Presentations**, select a presentation.
   b. Drag the presentation to a time slot during which you want it to play.
   c. Click and drag the selection handles to adjust playing time within one day.
   d. If you want the presentation to be a recurring event, double-click the highlighted presentation name in the calendar. In the Schedule Presentation window, set the following parameters:
      - **Presentation**: Specify which presentation you want to schedule.
      - **Active all day, every day**: Check this checkbox if you want the presentation to play 24 hours a day.
      - **Event time**: Specify the time during the day when you want the presentation to play by using the dropdown lists beside **Start** and **End**.
      - **Recurring Event**: Check this checkbox if you want the presentation to recur during specified times.
      - **Recurring pattern**: Specify the frequency for the recurrence. If you click **Daily**, you can specify **Every day**, **Every weekday**, or **Every weekend**. If you click **Weekly**, you can view a checklist of every day of the week. Specify the individual days of the week when you want the presentation to play.
- **Range of recurrence**: Use the calendar beside **Start** to specify the first day you want the presentation to play. If you want the event to stop recurring at some point, click **End by** and use the calendar to specify the date. If you don’t want it to stop, click **No end date**.
  
  e. Click **OK**. The adjustments made will be represented in the calendar.
  
  f. If prompted, indicate whether you want to replace the existing schedule and then click **OK**.
  
  g. Repeat steps b – e for each presentation you want to schedule.

6. (Optional) Specify debugging, and firmware preferences:
   
   a. Under **Debugging**, use the checkboxes to enable/disable **serial debugging** and **system log debugging**.
   
   b. Click **Specify Firmware Update** and indicate whether you want to update the firmware and to which version. The Firmware Update window is divided by BrightSign generation. In the section that corresponds to your BrightSign unit, select a firmware version or **Do not update**, and then click **OK**.

7. Publish the presentation:
   
   a. Click **Publish Schedule**. When the **Publish Complete** window opens, click **OK**.

**Publishing with Simple File Networking**

Publishing with Simple File Networking enables you to distribute your presentation to your BrightSign units via a web folder. Your player must be setup for Simple File Networking and with the correct **URL for web folder** used during setup. See [Adding BrightSign units to your Simple File Network](#) for details.

1. In BrightAuthor, save the presentations you want to publish by clicking **File > Save… As**

2. Add the presentations you want to publish:
   
   a. Click the **Publish** tab in the upper-left side of the screen.
   
   b. Click **Simple File Network** (above the Calendar).
   
   c. Under **Presentations**, click **Browse** to navigate to and select the folder where your presentations are stored.

3. Create schedules for each presentation you want to publish:
   
   a. From the list under **Presentations**, select a presentation.
b. Drag the presentation to a time slot during which you want it to play.
c. Click and drag the selection handles to adjust playing time within one day.
d. If you want the presentation to be a recurring event, double-click the highlighted presentation name in the calendar. In the Schedule Presentation window, set the following parameters:

- **Presentation**: Specify which presentation you want to schedule.
- **Active all day, every day**: Check this checkbox if you want the presentation to play 24 hours a day.
- **Event time**: Specify the time during the day when you want the presentation to play by using the dropdown lists beside **Start** and **End**.
- **Recurring Event**: Check this checkbox if you want the presentation to recur during specified times.
- **Recurring pattern**: Specify the frequency for the recurrence. If you click **Daily**, you can specify **Every day**, **Every weekday**, or **Every weekend**. If you click **Weekly**, you can view a checklist of every day of the week. Specify the individual days of the week when you want the presentation to play.
- **Range of recurrence**: Use the calendar beside **Start** to specify the first day you want the presentation to play. If you want the event to stop recurring at some point, click **End by** and use the calendar to specify the date. If you don’t want it to stop, click **No end date**.

  e. Click **OK**. The adjustments made will be represented in the calendar.

  f. If prompted, indicate whether you want to replace the existing schedule and then click **OK**.

  g. Repeat steps b – e for each presentation you want to schedule.

4. (Optional) Specify debugging and firmware preferences:

   a. Under **Debugging**, use the checkboxes to enable/disable **serial debugging** and **system log debugging**.

   b. Click **Specify Firmware Update** and indicate whether you want to update the firmware and to which version. The Firmware Update window is divided by BrightSign generation. In the section that corresponds to your BrightSign unit, select a firmware version or **Do not update**, and then click **OK**.

5. Publish the presentation:

   a. Under **Simple File Networking Parameters**, click **Set Parameters**.

   b. Under **Unit Configuration**:

      - Type the URL for your web folder. This must match the URL you entered when setting up your device for Simple File Networking.
• (Optional) **Connect to server**: Use the dropdown list to specify how often you want the player to connect to the server.

• (Optional) **Limit content downloads**: Click Yes or No to determine whether you want to place a time limit on downloads. If you click Yes, use the dropdown lists beside **Start of range** and **End of range** to specify the times during the day when content can download.
c. (Optional) Under **Logging**, check any of the following checkboxes to enable the corresponding logs and specify upload settings:

- **Enable playback logging**: Creates logs that specify when a playlist was used.
- **Enable event logging**: Creates logs that specify when events were triggered.
- **Enable diagnostic logging**: Creates logs that provide troubleshooting information.
- **On startup**: Uploads log files each time you start the unit.
- **At specific time each day**: Uploads log files daily, at the specified time. Use the dropdown lists to pick a time.
- **Relative URL for log handler**: Type the location where you want logs to be uploaded.

d. (Optional) Under **Rate Limit Network Download Traffic**, set parameters for download traffic. The options are divided into **Outside content download window**, **During content download window**, and **During initial downloads**.

- **Click Unlimited download rate** to set no limit.
- **Click Default limit** to use the default limit on downloads.
- **Click Specify limit** to enter a customized limit on downloads in the text field (in Kbits/seconds).

e. **Click OK**.

f. Under **Publish to**, click **Browse** to navigate to and select the location where you want to store the files.

- If you have a mapped drive or shortcut that points to your web folder, publish to that location.
- If you use FTP to transfer files to your web folder, publish to a folder on your computer and then use FTP software to copy the files to your web folder.

g. **Click Publish**. When the **Publish Complete** window opens, click **OK**.

---

**Publishing with Local Networking**

Publishing a presentation using a Local Network lets you distribute your presentation to your BrightSign units without using an Internet connection. This is convenient if you only have a small number of BrightSign units and are on a local network. With a Local Network, the BrightSign unit does not need to wait until it polls the web server to receive updates.
You can simply select a BrightSign unit on BrightAuthor and publish a presentation directly to it, sending updates immediately.
1. In BrightAuthor, save the presentations you want to publish by clicking **File > Save... As**

2. Add the presentations you want to publish:
   a. Click the **Publish** tab in the upper-left side of the screen.
   b. Click **Local Network** (above the Calendar).
   c. Under **Presentations**, click **Browse** to navigate to and select the folder where your presentations are stored.

3. Create schedules for each presentation you want to publish:
   a. From the list under **Presentations**, select a presentation.
   b. Drag the presentation to a time slot during which you want it to play.
   c. Click and drag the selection handles to adjust playing time within one day.
   d. If you want the presentation to be a recurring event, double-click the highlighted presentation name in the calendar. In the Schedule Presentation window, set the following parameters:
      - **Presentation**: Specify which presentation you want to schedule.
      - **Active all day, every day**: Check this checkbox if you want the presentation to play 24 hours a day.
      - **Event time**: Specify the time during the day when you want the presentation to play by using the dropdown lists beside **Start** and **End**.
      - **Recurring Event**: Check this checkbox if you want the presentation to recur during specified times.
      - **Recurring pattern**: Specify the frequency for the recurrence. If you click **Daily**, you can specify **Every day**, **Every weekday**, or **Every weekend**. If you click **Weekly**, you can view a checklist of every day of the week. Specify the individual days of the week when you want the presentation to play.
      - **Range of recurrence**: Use the calendar beside **Start** to specify the first day you want the presentation to play. If you want the event to stop recurring at some point, click **End by** and use the calendar to...
specify the date. If you don’t want it to stop, click **No end date**.

e. Click **OK**. The adjustments made will be represented in the calendar.

f. If prompted, indicate whether you want to replace the existing schedule and then click **OK**.

g. Repeat steps b – e for each presentation you want to schedule.

4. **(Optional) Specify debugging and firmware preferences:**

   a. Under **Debugging**, use the checkboxes to enable/disable **serial debugging** and **system log debugging**.

   b. Click **Specify Firmware Update** and indicate whether you want to update the firmware and to which
      version. The Firmware Update window is divided by BrightSign generation. In the section that corresponds
      to your BrightSign unit, select a firmware version or **Do not update**, and then click **OK**.

5. Publish the presentation:

   a. Under **Publish**, select a BrightSign unit.
      
      • If publishing to a new BrightSign unit, click **New unit**. Then click the **button. The Add BrightSign
        Unit window will open. Type the IP address of the new BrightSign unit, and click **OK**.

      • If you want to publish to a previously added BrightSign, click **Networked units**. Select a unit from the
        list of all networked units. Click **to refresh the list.

   b. Click **Publish**. When the **Publish Complete** window opens, click **OK**.

**Note**: *When publishing to a new BrightSign unit, the BrightSign Unit Setup window will open after you click Publish. See Adding BrightSign units to your Local Network for details.*
CHAPTER 7 – CUSTOMIZING PRESENTATIONS

This chapter will teach you all the different ways you can customize your presentations.

Setting zone properties

Whether you’re creating a single zone or a multi-zone presentation, you can customize the settings for each zone.

1. Open a presentation project by clicking **File > Open Presentation**.
2. Below **Zone** in the upper-left portion of the screen, click the zone whose properties you want to change.
3. Click **Zone Properties**. Set any of the following in the Edit Zone window:

**View mode:** Use the dropdown list to specify a setting for videos.
- Scale to fit: Scales the video to fill the screen without maintaining the aspect ratio. The video may appear stretched.
- Letterboxed and centered: Centers the video and adds black borders on the top and bottom. The aspect ratio is maintained.
- Fill screen and centered: Centers the video and fills the screen. The aspect ratio is maintained.

**Audio settings:** Use the dropdown list to specify the type of audio you want to use in the zone. You can select: Analog audio, Digital Audio (Stereo PCM), Digital Audio (Raw Multichannel), or Analog audio with HDMI Raw Multichannel.

**Image mode:** Use the dropdown list to specify a setting for images.
- Center image: Centers the image without scaling (may result in cropping if the image is too large).
- Scale to fit: Scales the image to fit the zone. The image is displayed as large as possible with the correct aspect ratio.
• Scale to fill and crop: Scales the image to completely fill the zone while maintaining the aspect ratio.
• Scale to fill: Scales the image to fill the zone without maintaining the aspect ratio.

**Initial volume (Video):** Set the initial volume for video files (0-100).

**Initial volume (Audio):** Set the initial volume for audio files (0-100).

**Live video:** Set attributes for live video feeds. Use the dropdown lists to select the Input and Video Standard types. In the text fields, enter parameters for Brightness, Contrast, Saturation, and Hue.
**Number of lines:** Set the number of lines of text in the Ticker zone.

**Time to display each line:** Set how long each line displays in the Ticker zone (in seconds).

**Rotation:** Use the dropdown list to select the angle of text in the Ticker zone.

**Alignment:** Use the dropdown list to set whether text is left aligned, right aligned, or centered in the Ticker zone.

**Text appearance:** Set whether text is animated or static in the Ticker zone.

**Foreground text color:** Click **Choose** and select a color for text in Ticker or Clock zones.

**Background text color:** Click **Choose** and select the color behind text in Ticker or Clock zones.

**Transparency:** Set the transparency of the Background text color in Ticker or Clock zones.

**Font:** Click **Browse** and set a font for text in Ticker or Clock zones. You can use any TrueType font. Click **Reset to System Font** to reset the font.

**Advanced:** Click the Advanced arrow to reveal the following options:
- **Background bitmap:** Click **Browse** to navigate to and select a file for a background image. Click **Yes** or **No** to determine whether you want to stretch the image to fill the zone. You can add a background bitmap to Ticker or Clock zones.
- **Safe text region:** Define the location (X,Y fields) and size (Width, Height fields) of the text region within the zone.

The settings in the Edit Zone window correspond to the type of zone you have selected. Here is a list of all the settings you can edit for each type of zone:
- **Video or Images zone:** View mode, audio settings, image mode, initial volume (video), initial volume (audio), and live video.
• **Video Only zone**: View mode, audio settings, image mode, initial volume (video), initial volume (audio), and live video.

• **Images zone**: Image mode.

• **Audio Only zone**: Audio settings, initial volume (audio)

• **Ticker zone**: Number of lines, time to display each line, rotation, alignment, text appearance, foreground text color, background text color, transparency, font, background bitmap, and safe text region.

• **Clock zone**: Rotation, foreground text color, background text color, transparency, font, background bitmap, and safe text region.

• **Background Image zone**: You cannot click **Zone Properties** for a Background Image zone. Choose a background image by selecting the Background Image Zone and dragging a file to the playlist area. If you only want a background color (instead of an image), do not add a Background Image zone. The background screen color can be changed in the Presentation Properties window. See [Setting presentation properties](#) for details.

4. Click **OK**.

5. Repeat steps 2 – 4 for each zone you want to edit in your presentation.

**Customizing template layouts**

If the predefined zone template layouts do not meet your needs, you can create your own templates. Complete the following steps:

1. Create a presentation project by clicking **File > New Presentation** and select a template that is most similar to the layout you want to use.

2. Click **Layout** (below the Edit tab) and create a template by doing any of the following:
   - Resize a zone by clicking the zone in the preview image and dragging the selection handles. Alternatively, you can enter the **Size** information in the left side of the screen. **W** corresponds to the width of the zone, and **H** corresponds to the height of the zone.
   - Change the position of a zone by clicking the zone and dragging it to the desired position. Alternatively, you can enter the **Position** information in the left side of the screen. **X** corresponds to the position on a horizontal axis, and **Y** corresponds to the position on a vertical axis.
• Add a zone by clicking **Add zone**, typing a **Zone name**, selecting the **Zone type**, and then clicking **OK**.
- Make two or more zones the same size by pressing Ctrl+Click to select the zones you want to resize. On the menu bar, click Format > Make same size and select a resize option.
- Align two or more zones by pressing Ctrl+Click to select the zones you want to align. On the menu bar, click Format > Align and then select an alignment option.
- Center or more zones by pressing Ctrl+Click to select the zones you want to center. On the menu bar, click Format > Center in form and then select Horizontally or Vertically.

**Tip:** You can layer zones on top of each other. For example, you can place a Ticker or Clock zone on top of a Video Only zone, and then edit the transparency in the Ticker or Clock zone to control how much of the underlying video is visible.

- Remove an unwanted zone by clicking it in the preview image and then pressing Delete on your keyboard.
- Rename a zone by clicking it in the preview image, and then typing in the Name text field in the left side of the screen.

**Note:** The preview image is always displayed as a landscape. If your display is a portrait and you have selected this monitor orientation when creating the project, refer to the portrait image in the left side of the screen to see how your zones will appear to a viewer.

3. Click Save Template (in the lower-left portion of the screen), enter a name for the template, and then click OK.
4. To use a custom template in a new presentation, click the View dropdown list in the upper-right corner of the Template window. Select User Defined Templates to view your templates. Click a template and then click Choose to use it in the presentation.

**Setting presentation properties**

You can edit properties that apply to an entire presentation. These are based on your current default property settings. To change the default settings, see Setting default properties. To edit presentation properties, complete the following steps:

1. Open a presentation project by clicking File > Open Presentation.
2. On the menu bar, click File > Presentation Properties.
3. Click the Main tab and set any of the following:
• **Connector type**: Use the dropdown list to indicate the type of connector you are using for your display (HDMI, VGA, or Component).

• **Screen resolution**: Use the dropdown list to set a resolution supported by your display.

• **RSS update frequency**: Use the dropdown list to how often you want the BrightSign to check for RSS feed updates.

• **Background screen color**: Click Choose to select a background color that appears behind your zones.

• **Language**: Use the dropdown list to select a language for your presentation.

4. Click the **I/O** tab and click **Input** or **Output** next to each GPIO port to indicate whether the port is sending or receiving information.

5. Click the **Interactive** tab and set any of the following:
   - **Serial**: For each serial port: Port (number), Baud rate, Data bits, Parity, and Stop bits. Toggle between Binary and ASCII mode (Protocol), and set EOL characters (CR, LF, LF + CR) for Send and Receive EOL. Note: the standard part is port 0 and the 5V TTL port is port 1.
• **UDP**: The UDP destination address (type below **Specific IP Address** in dotted quad form, or click **All devices on the local subnet**), and the UDP Destination and Receiver ports.

• **Touch**: Click a Cursor option to set whether the cursor is always hidden, always visible, or present only if there is more than one touch region on the screen (auto display cursor). Check the **Flip coordinates** checkbox to reverse the coordinates of the check screen. Use this option only if the touch screen coordinates appear to be reversed.

6. Click the **Buttons** tab and use the dropdown list to select the type of button panel you are connecting to your BrightSign. Click **Automatically configure which buttons are enabled** or **Specify which buttons are enabled** and check the checkboxes to manually enable buttons. Repeat for each button panel you are connecting.

7. Click the **Audio** tab and set any of the following:
   - Audio Minimum and Maximum Volume (0 – 100).
   - HDMI Minimum and Maximum Volume (0 – 100).

8. Click the **Media List** tab and set the following:
   - **Return to start after inactivity**: Click **Yes** to set Media Lists to return to the start of the list after a period of inactivity.
   - **Inactivity timeout (seconds)**: If you clicked **Yes** above, type a number in the text field to specify how long Media Lists will wait through a period of inactivity before returning to the start.
9. Click the **Autorun** tab and click **Standard Autorun** or **Select custom Autorun** to specify a different autorun file for the presentation. Click **Browse** to navigate to and select the autorun file.

![Presentation Properties](image)

9. Click the **Image Cache** tab. Here, a list of all media files in your playlist is displayed. Check the checkboxes to store certain files in an image cache for faster loading.

10. Click the **Variables** tab to create User variables and enable Media Counters.
   - **Media Counter**: Media Counters record how many times a file in the presentation has played. They can be viewed in Live Text or extracted from the BrightSign via USB. Media Counters are not recorded unless you check the **Automatically create media counter variables** checkbox in the Variables tab. When enabled, Media Counters are recorded for every file in the presentation and can be extracted via USB. However, in Live Text, only the Media Counters individually added can be viewed. For details on retrieving all Media Counters via USB, see **Using advanced tools**.
   - **User variable**: User variables are customizable values that can be used in commands or displayed in Live Text. When used in Live Text, User variables display the current value of the variable. This value can continually change throughout a presentation. The value of a User variable can be changed during a presentation by using a **Set Variable** or **Reset Variable** command.

   The User variables can be used in the following commands: Set Volume, Increment Volume, Decrement Volume, Send UDP, Serial-send string (EOL), Serial-send string (no EOL), Serial-send byte, Serial-send
bytes (comma separated), Synchronize, Send Zone Message, Link Zones, GPIO On, GPIO Off, GPIO Set State, BrightControl – Send Ascii String, BrightControl – Philips Set Volume, Pause.

For example, if you add a Set Volume command to your presentation and use a static value like 50, the volume will always be set to 50 when the command occurs. If you use a User variable instead, the volume will be set to the current value of the variable, which could be any number of values based on your Set Variable commands and when the User variable is used.

To use a User variable in a command, add the desired command as you normally would. See *Adding Commands* for details. In the Parameters field, type the exact name of the variable in between two dollar signs on each side. For example, “$$variable1$$”. BrightAuthor will not recognize the variable without the dollar signs.
To create a User variable, click the Add Variable button in the Variables tab. In the Add User Variable window, type a name and default value for your variable. Whenever variables are reset (via the Reset Variables command), the variable will return to this default value. To edit a previously created User variable, type a new name or default value in the Variables tab. To delete a User variable, click the X beside the appropriate variable.

11. Click **OK** when you are finished editing the presentation properties.

**Setting default properties**

Whenever you create a presentation project, the presentations settings are based on the default settings. If you often use the same set of properties, you can save time by changing the default property settings to what you use most often. Keep in mind, changing the default settings does not adjust the current project. Changes will apply to new presentations. To edit default settings, complete the following steps:

1. On the menu bar, click **Edit > Preferences**.
2. Click the **Video** tab and set the following video settings:
   - **Volume**: Specify a value between 0 and 100.
   - **Live video – time on screen**: Set a default period for live videos to remain on screen (in seconds).
3. Click the **Images** tab and set the following:
   - **Slide transition**: Use the dropdown list to set an effect for image transitions.
   - **Slide delay interval**: Set how long each image displays (in seconds).
4. Click the **Interactive** tab and set a default timeout period for media files (in seconds).
5. Click the **Clock** tab and use the dropdown list to set a language and use its predefined date and time format. To customize the format, click **Customize**, enter the settings you want to use, and then click **OK**.
6. Click the **Live Text** tab and set the following:
• **Alignment**: Use the dropdown list to set whether Live Text is left aligned, right aligned, or centered.

• **Foreground text color**: Click Choose and select a color for Live Text (the letters).

• **Background text color**: Use the checkbox to determine whether you want to include a background text color for text fields. Click Choose and set a default color for the backgrounds.

• **Transparency**: Drag the bar to set a transparency setting for background text colors.

• **Font**: Click Browse and set a font for Live Text. You can use any TrueType font. Click **Reset to System Font** to reset the font.

• **Font size**: Click Automatic or Fixed point size to enter a value for Live Text font size (1-500).

7. Click the **Networking** tab and check the checkboxes to enable/disable the following: BrightSign Network, Local Networking, Bonjour, and Simple File Networking. Note: if you are publishing with Local Networking but are not seeing your BrightSign units on the network, disabling Bonjour can help.

8. Click the **UI** tab and set the following:

   • **Publishing**: Check the checkboxes to indicate whether you want to **Show file overwrite dialog** and **Copy and replace duplicate files when publishing locally**.

   • **Save properties**: Check the checkbox to **Show save properties dialog**.

   • **Transitions**: Set the display mode for transitions in your interactive playlist. You can select: Automatic, Always display line, or Always display label. For labels, you can set whether you want them to be on the **Right** or **Bottom** of files in your playlist area.

9. Click **OK**.
CHAPTER 8 – MANAGING YOUR NETWORK

You can manage your BrightSign and Local networks through BrightAuthor.

Permissions
Administrators of BrightSign Network accounts can create separate accounts with access to their BrightSign Network. These accounts (called User Accounts) can be assigned to roles with various sets of permissions in both the web user interface and BrightAuthor.

When you sign in to BrightSign Network in BrightAuthor, access to features of BrightAuthor will depend on permissions that were determined by the Account Administrator. Regardless of permissions, BrightAuthor appears the same to all users. However, attempting to use blocked features will result in an error message. If you are an Account Administrator and want to change a User Account’s permissions in BrightAuthor, this must be done through the web UI.

Viewing unit statuses
In BrightAuthor, you can view the status of all units on your BrightSign Network or Local Network.

Local Network – Viewing unit status on your Local Network lets you view all units and their info, view active presentations for units, specify a username and password for units, and remove units from the network.

1. Sign in to BrightSign Network by clicking **Tools > Sign in to BrightSign Network**.
2. Click the **Manage** tab.
3. Click **Local Network** (below the Manage tab). Here, a list of all units on the Local Network is displayed. The list contains all unit names, descriptions, uptimes, and current active presentations.
4. Right-click a unit to: **Remove the unit**, **Show all units**, **Specify a username and password**, and view **Info**. Clicking **Info** opens the Unit Properties window. Here, you can view the unit ID, its IP address, BrightSign model, firmware version, and autorun version.
### Status

<table>
<thead>
<tr>
<th>Status</th>
<th>Group</th>
<th>Device Count</th>
<th>Scheduled Presentations</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Unassigned</td>
<td>2</td>
<td>Project 27</td>
</tr>
<tr>
<td></td>
<td>Group Two</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Group One</td>
<td>1</td>
<td>My Project</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Status</th>
<th>Name</th>
<th>Description</th>
<th>Active Presentation</th>
<th>Last connection</th>
<th>Connects every</th>
</tr>
</thead>
<tbody>
<tr>
<td>green</td>
<td>My_BrightSign</td>
<td>none</td>
<td></td>
<td>3/8/2012 12:50:16 PM</td>
<td>5 minutes</td>
</tr>
</tbody>
</table>
**BrightSign Network** – You can view the activity status of all units in your BrightSign Network, the groups to which units are assigned, the scheduled presentations for each group, the last connection time for each unit, and how often each unit is set to connect to the network.

1. Sign in to BrightSign Network by clicking **Tools > Sign in to BrightSign Network**.
2. Click the **Manage** tab.
3. Click **Status** (below the Manage tab).
4. Click the arrow beside a group to view its details. Here you can view a list of all devices in the group, whether they are active, their names and descriptions, current active presentations, last connection times, and how often each connects to the server.
5. Right-click a device in a group to: **Edit**, **Delete**, check **Info**, or check **Download progress**.
6. (Optional) Sort the list by clicking the column you want to use as the sorting criteria. For example, to sort by status, click the status column. Click again to switch between ascending and descending order.

**Managing groups**

Groups let you distribute presentations to a specific set of BrightSigns. Publishing a presentation to a group delivers it to all BrightSigns within that group. BrightAuthor includes two default groups: Default and LocalTest. However, you can create as many groups as you need.

1. Sign in to BrightSign Network by clicking **Tools > Sign in to BrightSign Network**.
2. Click the **Manage** tab.
3. Click **Status** (below the Manage tab).
4. Do any of the following:
   - To create a group, click **Add Groups** (in the lower-left corner of the screen). Type a name for the group, and then click **OK**.
   - To delete a group, right-click a group, and then click **Delete**.
   - To move a device to a different group, click the arrow for the group that contains the device. Then click the device and drag it to the desired new group.
**Viewing presentations**

Viewing BrightSign Network presentations lets you see all presentations uploaded to the network, which groups they belong to, which presentations are active, and when they were last modified.

1. Sign in to BrightSign Network by clicking **Tools > Sign in to BrightSign Network**.
2. Click the Manage tab.
3. Click Presentations (below the Manage tab).
4. Click the arrow beside a presentation to view which groups are currently using the presentation.
5. (Optional) Sort the list of presentations by clicking the column you want to use as the sort criteria. For example, to sort by name, click the name column. Click again to switch between ascending and descending order.
Viewing your library

Viewing your library lets you see all the content you’ve uploaded to your BrightSign Network.
1. Sign in to BrightSign Network by clicking **Tools > Sign in to BrightSign Network**.
2. Click the **Manage** tab.
3. Click **Library** (below the Manage tab). Here, all files uploaded to the network are displayed. Files with a green check mark are currently active. Do any of the following:
   - Switch between thumbnail and list view: Click the icons in the upper-right portion of the screen.
   - View item info: Right-click an item and click **Info**. Here you can view: file size, type, date modified, date uploaded, all presentations using the file, and all dynamic playlists using the file.
   - Delete an item: Right-click a file and click **Delete**. Keep in mind, you can only delete files that aren’t currently active.
   - Refresh the library: Click **Refresh** in the upper-right portion of the screen.

**Viewing dynamic playlists**

You can view all dynamic playlists, the presentations that contain dynamic playlists, and when the playlists were last modified.

1. Sign in to BrightSign Network by clicking **Tools > Sign in to BrightSign Network**.
2. Click the **Manage** tab.
3. Click **Dynamic Playlist** (below the Manage tab). Here, a list of all dynamic playlists is displayed. Playlists with a green checkmark are currently part of a presentation. Do any of the following:
   - Delete a playlist: Right-click a dynamic playlist and then click **Delete** to erase it.
   - View info: Right-click a dynamic playlist and then click **Info** to see when the dynamic playlist was last modified, and a list of all presentations that contain the dynamic playlist.
   - Sort the list: You can adjust the list of dynamic playlists by clicking the column you want to use as the sort criteria. For example, to sort by name, click the name column. Click again to switch between ascending and descending order.
Using advanced tools

Advanced tools let you remotely control units on your BrightSign Network, or set up a USB flash drive to retrieve device data and perform device actions. After setting up a USB flash drive, inserting it in a BrightSign will extract the specified data or perform the specified actions (e.g. reboot the player). The Advanced Tools window is divided into 3 tabs: the Setup USB Drive tab, and the Update Autorun and Unit Control tabs, which are only available if you have a BrightSign Network account.

Complete the following steps to set up a USB flash drive:

1. Click **Tools > Advanced**.
2. Click the **Setup USB Drive** tab.
3. Click any of the following checkboxes to determine what actions you want to occur when inserting the USB flash drive into the player:
   - Copy variables database: Extracts the data for all User variables and Media Counters.
   - Copy log files: Extracts all log files.
   - Delete log files: Deletes all log files on the BrightSign.
   - Reboot: Reboots the BrightSign.
   - Display status on screen during data capture: Displays the status on the display while the USB flash drive is inside the BrightSign.
4. Click **Setup drive** and navigate to the location of the USB flash drive on your computer.
5. When the Setup Complete window opens, click OK.
6. Remove the USB flash drive from your computer and insert it in the BrightSign.
7. If you are extracting data from the BrightSign, reinsert the USB flash drive into your computer to retrieve the data.

Complete the following steps to control units on your BrightSign Network:

1. Sign in to BrightSign Network by clicking **Tools > Sign in to BrightSign Network**.
2. Click **Tools > Advanced**.
3. Click the **Update Autorun** tab. A list of all your groups is displayed here. Check the checkboxes and then click **Update now** to update the Autorun version for those groups.
4. Click the **Unit Control** tab.
5. In the **Serial Number** field, type the serial number of the unit you want to control.
6. Click the **Action** dropdown list to select the action you want to perform:
   - **Reboot unit**: Restarts the BrightSign.
   - **Upload logs**: Uploads log files based on the upload logs setting you selected when setting up the unit.
   - **Recover – reformat**: Puts the unit in recovery mode and reformats the unit’s storage card.
   - **Recover – don’t reformat**: Puts the unit in recovery mode and downloads the latest Autorun script to the storage card without reformatting it.
7. (Optional) Click **Add action** to add another action, or remove an action by clicking **Remove action**.
8. Click **Close**.
Can I use BrightAuthor with the HD600 or HD2000?
No. Currently, BrightAuthor only supports the HD110, HD120, HD210, HD210w, HD220, HD410, HD810, HD1010, HD1010w, HD1020, and TD1012.

Can I open the autoplay.xml file using BrightAuthor?
No. The autoplay.xml file generated when you publish a presentation is a playlist file. This file includes only the information required for playback on a BrightSign. It is not the same as a presentation project file.

How do I use a different font?
To use a different font, browse to a folder on your computer that has a true type font (e.g. in a Ticker zone, click Zone Properties, and then click Browse beside font). This font will be copied to the SD card when you publish the presentation. You can use your own custom fonts or download free TrueType fonts from the web.

Can I export a template?
Yes. Although there isn’t a template export option, you can save a presentation project with the desired template layout, and then transfer it to another computer. You can then open the project in BrightAuthor, and then save the template (Layout > Save Template).

Can I use the scheduling feature on the HD110 or HD410?
All units manufactured and purchased since November 2010 have a real time clock which supports scheduling. Older HD110 and HD410 models do not support scheduling.

Why does BrightAuthor take a long time to process my folder?
If the folder you selected has a large number of images and videos, the Media Library may take a few minutes to update. Please be patient.

**Why can’t BrightAuthor locate my files when I try to publish my presentation?**

If you copy a presentation project from one computer to another, or move or rename files used in a BrightAuthor project, BrightAuthor cannot locate the files and you will receive an error message when you try to publish. To resolve the error, you must remove the files from each zone’s playlist in the presentation, and then add them again.

**Why are some of my videos missing thumbnails in the Files tab?**

The thumbnails are generated by codecs installed on your computer. You can download codecs to resolve the problem. For example, if you’re missing thumbnails for your transport streams, you can try downloading a codec such as K-Lite.

**What do I do if BrightAuthor crashes while I’m using it?**

For any errors or crashes you encounter while using BrightAuthor, please post a description of the problem in the forums ([http://support.brightsight.biz/forums](http://support.brightsight.biz/forums)) or send us an email at support@brightsign.biz and include the following information:

- Steps to duplicate the problem (or indicate that you can’t duplicate it)
- Any error dialogs you saw, including text in the dialog
- The contents of your event log right after the crash. You can find the log in this folder: C:\Users\Owner\AppData\Local\BrightSign\BrightAuthor\. Look for a subfolder named after the BrightAuthor version number, such as 2.4.0.
- A copy of the presentation project where you experienced the problem
APPENDIX A – REMOTE CONTROL PROTOCOLS

Complete the following steps to set up your BrightSign to communicate with a remote control:

Create an interactive presentation (see Making a presentation interactive).

1. Define an interactive event with the Remote Input event.
2. In the Remote Input Event window, specify the remote input with any of the following remote control codes:

   WEST
   EAST
   NORTH
   SOUTH
   SEL
   EXIT
   PWR
   MENU
   SEARCH
   PLAY
   FF
   RW
   PAUSE
   ADD
   SHUFFLE
   REPEAT
   VOLUP
   VOLDWN
   BRIGHT

3. Repeat the above steps for each remote input you want to define.